2 Replies Latest reply on Aug 23, 2018 3:07 AM by Ankit Bajpay

    could not load solidworks dll: sldshellutils

    Bill Noel

      Upon using Pack & Go in Solidworks 2018 I am greeted with

       

      could not load solidworks dll: sldshellutils.

        • Re: could not load solidworks dll: sldshellutils
          Iain McEwen

          This problem is generally caused by an unregistered DLL. Register the DLL by following these steps:

           

          1. Go to 'Start' > Type "cmd" and press "Enter" to open a Command Prompt.

          2. Copy and paste the following line into the command prompt by right-clicking anywhere in the window and selecting "Paste":

           

          regsvr32 "C:\Program Files\Common Files\SolidWorks Shared\sldshellutils8u.dll"

           

          Press Enter to run the command. This will register the missing dll.

           

          First, check that this DLL file appears in that location!

          • Re: could not load solidworks dll: sldshellutils
            Ankit Bajpay

            Dear Sir,

             

            You can find the solution for this in SOLIDWORKS  Knowledge Base.

             

            For Standalone installs:

            1. Click 'Start', click 'Run', type "regedit" in the 'Open' box, and then click 'OK'.

            2. Locate and click the following subkey in the registry:   HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer.

                            Note: If this subkey does not exist, create it.

            3. In the 'Edit' menu, point to 'New', and then click 'DWORD Value'.

            4. For the DWORD name, type "RemappedElevatedProxiesPolicy", and then press 'Enter'.

            5. Right-click 'RemappedElevatedProxiesPolicy', and then click 'Modify'.

            6. In the 'Value' data box, type 1, and then click 'OK'.

            7. Run a Repair of your SOLIDWORKS Installation (S-050527).

            8. After the application installs successfully, reset the 'RemappedElevatedProxiesPolicy' DWORD value to "0" to re-enable the security fix for KB 3072630.

             

            For Administrative Image installs:

            1. Uninstall SOLIDWORKS from Programs and Features.
            2. Click 'Start', click 'Run', type "regedit" in the 'Open' box, and then click 'OK'.
            3. Locate and click the following subkey in the registry: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer.

            Note: If this subkey does not exist, create it.

            1. In the 'Edit' menu, point to 'New', and then click 'DWORD Value'.
            2. For the DWORD name, type "RemappedElevatedProxiesPolicy", and then press 'Enter'.
            3. Right-click 'RemappedElevatedProxiesPolicy', and then click 'Modify'.
            4. In the Value data box, type "1", and then click 'OK'.
            5. Install SOLIDWORKS from your Administrative Image.
            6. After the application installs successfully, reset the 'RemappedElevatedProxiesPolicy' DWORD value to "0" to re-enable the security fix for KB 3072630.