13 Replies Latest reply on Mar 13, 2018 11:03 PM by Alin Vargatu

    Prevent CommandManager Splitting

    Jordan Skoblenick

      Hi there,

       

      When I start "Copy with Mates" the CommandManager is split automatically into 2 panes, with "Copy with Mates" barely showing (I've attached a screenshot of what I mean)

       

      After finishing "Copy with Mates" I can double-click the splitter bar to un-split the CommandManager.

       

      However, the next time I do "Copy with Mates", the CommandManager splits again, and I have to repeat this process.

       

      I tried checking "Lock CommandManager and toolbars" by right-clicking the ribbon and choosing "Customize", but this had no effect.

       

      How can I prevent "Copy with Mates" from splitting the CommandManager?

       

      Thanks!

       

      EDIT: This is in SolidWorks 2018 SP1.0

        • Re: Prevent CommandManager Splitting
          David Matula

          keep dragging the bar back to the top and if you close out  the program without it crashing it may recall the setting.  my best guess. 

            • Re: Prevent CommandManager Splitting
              Jordan Skoblenick

              I tried dragging the bar to the top, saving and closing.

               

              When I re-open SW the bar appears at the very bottom of the CommandManager (not at the top where I had dragged it to pre-closing).

               

              Tried a few times, same thing. Thanks though!

                • Re: Prevent CommandManager Splitting
                  Tim Ordway

                  While in your feature manager view, drag the bar to the bottom before using Copy With Mates.

                    • Re: Prevent CommandManager Splitting
                      Jordan Skoblenick

                      Tim,

                       

                      When I start SW the bar is already at the bottom. I tried dragging it up, then dragging it back to the bottom, before starting "Copy with Mates". Unfortunately the CommandManager was still split.

                       

                      I have attached a video showing what I mean. Thanks for your reply!

                        • Re: Prevent CommandManager Splitting
                          Jeremy Feist

                          weird.

                           

                          copy with mates does not split my feature tree. it puts the copy with mates property manager in the property manager tab like it is supposed to. I did not find a setting for this, except maybe one of these two (which I can't try out). also, I am not able to manually split the feature manager.

                          Capture.PNG

                          • Re: Prevent CommandManager Splitting
                            Jim Wilkinson

                            Hi Jordan,

                             

                            The way it should work is if the splitter is at the top or bottom, the PropertyManager should take over the entire vertical space, completely hiding the FeatureManager tree. If the splitter is in the middle, there are two possible behaviors:

                            1. If "Auto-size PropertyManager when panels are split" is ON, the PropertyManager will show in the bottom pane and move the splitter while the command is running to show the contents of the PropertyManager.
                            2. If "Auto-size PropertyManager when panels are split" is OFF, the PropertyManager will show in the bottom pane and not move the splitter at all.

                             

                            So it looks like you are getting behavior #1 even if your splitter is at the top or bottom which is not correct behavior.

                             

                            Does this only happen on this assembly? If you open a new assembly file (with no components in it) and then run the Copy with Mates command, does the same thing happen? If so, where is the splitter bar on the new assembly?

                             

                            If not, try one more thing; on the assembly that is giving you trouble, double click the splitter bar. This should automatically put it all the way at the top. Then try Copy with Mates. Does the same problem occur? If so, does the same problem occur with other commands like Insert Components or Mates?

                             

                            Report back on what you find.

                             

                            Thanks,

                            Jim

                              • Re: Prevent CommandManager Splitting
                                Jordan Skoblenick

                                Hi Jim,

                                 

                                Thanks for taking the time to reply.

                                 

                                Currently, "Auto-size PropertyManager when panels are split" is on.

                                 

                                I tried a new assembly as you indicated. The splitter bar appears at the bottom. When I click "Copy with Mates" from ribbon, the dialog appears correctly in the top pane of the CommandManager.

                                 

                                When I went back to my working assembly (splitter also at bottom), I tried "Copy with Mates" from the ribbon and it works correctly as well! This is very interesting.

                                 

                                I didn't think to include this in my original post, but I usually invoke "Copy with Mates" by RMB on either the part itself, or on a part in the tree. It's only when I invoke "Copy with Mates" by RMB that the issue I'm seeing occurs.

                                 

                                If I double-click the splitter bar (or move it to the top), "Copy with mates" by RMB works correctly.

                                 

                                Next I tried turning "Auto-size PropertyManager when panels are split" OFF.

                                 

                                With the splitter bar at the bottom, I tried "Copy with Mates" by RMB again. The screen changes such that "Copy with Mates" is active, but the dialog is not visible because it appears on the lower pane, which is hidden/isn't auto-sized now.

                                 

                                "Insert Component" and "Mate" from the ribbon work correctly. "Mate" by RMB a part works the same as "Copy with Mates" by RMB above.

                                 

                                Cheers,

                                Jordan

                                  • Re: Prevent CommandManager Splitting
                                    Jim Wilkinson

                                    Hi Jordon,

                                     

                                    Sorry for the delay.

                                     

                                    I have confirmed that if I have the splitter at the bottom and run Copy with Mates or Mate from the RMB, then it does indeed split, but running it from the CommandManager (our name for the ribbon), then it doesn't split. As a workaround, I would suggest opening your assembly template, dragging the splitter to the top, and resaving your assembly template. Then new assemblies will have the splitter at the top, not the bottom and you won't encounter this issue. On existing assemblies, you'll have to drag the splitter to the top.

                                     

                                    Theoretically, I don't see why there should be a difference between invoking via the CommandManager vs. the RMB and consider it a bug, so if you would like to see it fixed, I would suggest submitting it to your reseller so they can get an SPR for it. For clarification, the "dialogs"  that appear on the left by default are called "PropertyManagers"; you had referred to it as "CommandManager", which again is our name for the tabbed toolbar interface for the buttons similar to what Microsoft calls the Ribbon. We don't call it the Ribbon for a couple of reasons; 1) we actually released this before Microsoft's ribbon existed so it already had the CommandManager name, 2) it does not work exactly like the MS ribbon since it is customizable, can be undocked or docked on the left or right, etc. I just wanted to clarify that so when reporting to your reseller, there isn't confusion over the terminology.

                                     

                                    Thanks,
                                    Jim

                                      • Re: Prevent CommandManager Splitting
                                        Jordan Skoblenick

                                        Jim,

                                         

                                        Thanks for the clarification on PropertyManager vs CommandManager. Sorry about that!

                                         

                                        Also, thanks for the workaround. I will give that a shot in the meantime. I find myself dragging the splitter bar up on new assemblies, so changing the "assembly template" will save that step.

                                         

                                        I would definitely like to see the bug fixed. Is it possible to submit an SPR without going through a reseller? We were very disappointed with our current reseller (Javelin), to the point where we cancelled our support contract with them. Right now we are not with any particular reseller.

                                         

                                        Cheers,

                                        Jordan

                          • Re: Prevent CommandManager Splitting
                            David Matula

                            I went back and tried to see if I got the same results since I really don't use copy with mates...im old school enough and just insert  components and try and use the smart mates set up in parts to put in my components.  It is annoying to have to drag the bar all the time....send in a tech support ticket to your var.  maybe they can tell you where the setting is and or report the bug if you really found one.