2 Replies Latest reply on Feb 23, 2018 6:39 PM by Josh Hixon

    Why does copy tree leave me a read only part that is broken?

    Josh Hixon

      I had not used the copy tree feature much in PDM standard but thought I would try to start using it for some assemblies that get used as templates for similar products. I am consistently getting an error when using it. Here is what I am doing:

      1. Filter for parts that are marked yes for copy
      2. Choose new file location
      3. make sure naming drawings after parts is unchecked. (Shop and Submittal drawings are separate files.)
      4. replace current name with a new name for all files.
      5. Make sure to not check in files on copy
      6. hit the copy files button.

       

      What I get every time I do this, is a part contained within the assembly that errors with a messages saying it is being used exclusively by another application. Then when I open that part, it is read-only but says I have it checked out. Trying to check it in leaves me with the same error message about being used by another application. The only thing I can do is save the part as a new name. The other issue is that I delete that part from PDM, but it is not really gone. I can never again save a file under that same name, even though there is not a visible part anywhere within PDM named the same. Any solutions or anything I am doing that is causing this?  I can not post the files as they are for work.  My VAR is coming in next week to upgrade us to PDM Professional, and we will be discussing this issue, but it is driving me crazy right now.