AnsweredAssumed Answered

SW 2009 reporting error with belt feature.

Question asked by Joe Dunfee on Feb 5, 2009
Latest reply on Feb 9, 2009 by Neil Larsen
I've had this happen several times now; I create a belt feature, and SW complains saying that the pulley's are fixed. But, I have unchecked the check box to have the belt size drive the pulley position. I.e. the pulley's are all fixed and I want the belt to adjust to fit the pulleys.

I called my dealer, and was preparing to show him the error, so I right-clicked the belt feature and choose to edit it. Then, I escaped out of it, without any changes. The error disappeared. Note that I have made several such attempts before, trying to force SW to re-evaluate the belt. I also tried checking the box to have it rebuild that way, and then re-editing the feature and unchecking the box. I also tried the standard Cntl-Q.

When this problem first appeared, and I couldn't resolve it, I decided to just recreate the belt, but that didn't stop the problem. It looks like most of the time, SW was ignoring that this check box was unchecked.

Anyone else having problems with belts?

Outcomes