5 Replies Latest reply on Feb 5, 2018 6:53 PM by Ryan Dark

    Syntax is incorrect error

    Swme Eng

      Hello all, one of my installs is now plagued by the persistent syntax is incorrect error, I tried the fixes described here:

       

      SOLIDWORKS

       

      As well as the one found here

      http://www.goengineer.com/2015/08/28/quick-fix-for-solidworks-install-error/cad-administration/

       

      I have tried clean installs, repairs, and nothing is fixing the problem. I am running 2016 SP5.0. Has anyone else found any other fixes?

        • Re: Syntax is incorrect error
          Ryan Dark

          Hi Swme Eng,

          The fix you cited from the www.goengineer.com website would only apply to versions of SOLIDWORKS 2015 SP4.0 and previous.  After that, SOLIDWORKS releases should contain the necessary change that stops those errors from happening.  Do you have an image of the error you are running into specifically that you can post up here?

            • Re: Syntax is incorrect error
              Swme Eng

              Ryan, any time I try to create an equation, I get the error "The syntax is incorrect." I am unable to share any screenshots unfortunately.

                • Re: Syntax is incorrect error
                  Ryan Dark

                  If you are not able to post images, videos, or parts, with these errors then it is going to be tough to get you help from this forum.  Have you asked your VAR for assistance on this?  You could have a confidentiality agreement with them that would let you get this investigated further.

                    • Re: Syntax is incorrect error
                      Swme Eng

                      Our VAR is pretty useless when it comes to complex issues like this, and the restrictions go beyond something a confidentiality agreement would cover.

                       

                      It may help to know that this happens on every single part and every time I try to create and equation.I have confirmed with other computers that it is not a template issue, and not  a file issue, it seems to be unique to this one installation.

                        • Re: Syntax is incorrect error
                          Ryan Dark

                          Well, without knowing a lot more and given what you have supplied so far I might recommend to burn it with fire (like this: GoEngineer - SOLIDWORKS Clean Installation).  If there is anything damaged in the installation itself that would clear it out.  However, if the issue remains then there are likely broader issues within either the user account or other Microsoft installations.  At that point, you may was well re-image/format the machine for as much work as it would take to fix those issues.