1 Reply Latest reply on Jan 23, 2018 10:04 PM by Brooke Colon

    Integrity checks have failed - Save Bodies

    Brooke Colon

      When I run the save bodies feature it saves the bodies ( I actually see them saved in the designated folder ), but then I get a message saying "Failed to save [ ].SLDPRT Integrity checks have failed" and I don't get my assembly. Then it says updating and will go through this cycle continuously if I don't exit out with task manager or just interrupt it with close out solidworks. I've tried looking around and it doesn't seem like anyone's reported this issue before. I ran the check tool to see if there were any issues around the model, none. I also ran the save bodies feature along three different  (top, middle, bottom) sections to see if there was an area it just wasn't comfortable with, again no problems, created the assemblies and parts just fine. Its only when I try to do the whole thing that this issue occurs. Also I have to create the assembly this way because the geometry is so organic that its impossible to create mates, but I can import the multiple parts in their correct orientations and positions this way. Does anyone have an idea of how to fix this?

        • Re: Integrity checks have failed - Save Bodies
          Brooke Colon

          Edit: The next paragraph was my original reply. However immediately after saving, I think what really did the trick was checkmarking the Consume Cut Bodies box in the Save Bodies feature. Since I mainly wanted the assembly I didn't mind since I can just build the part again "relatively" easily. The main issue was that the part was having issues saving, so the Consume Cut Bodies just eliminates having to save the bodies in the part file.

           

          After a lot of fiddling I somehow got the feature to work. I used the Checking Model Geometry page in help.solidworks.com. It highlights a feature to "increase the level of error checking" by turning on Verification on rebuild in Tools>Options>Performance. I had used the Check Entity tool before but it wasn't catching any errors, and honestly, turning on Verification on rebuild didn't highlight any errors or complications either. But after running it, when I tried to use the Save Bodies feature again it was able to get through it all (after updating several times of course). So I ran with it, but would still like some sort of explanation if it can be provided.