14 Replies Latest reply on Apr 17, 2009 7:02 PM by Edward Wagner

    Meshing Parts

    Jean Carpentier
      I have an assembly that contains many parts.
      I open a part individually to start a study.
      The part will not mesh.
      Later I learn I cannot get any of the parts in the assembly to mesh.
      I create a simple 1" cube and it will mesh.
      Anyone!!!
        • Meshing Parts
          Anthony Botting
          Hi Jean can you tell me if you get any messages and what they say?
          • Meshing Parts
            Chad Schmidt
            Are you on a network?
            • Meshing Parts
              Mans Collner
              Check the length of the search-path to the part-file of the part you trying to mesh. It seems that SW right now have a problem with long search-paths.
              I moved all my simulation files to a folder direct under C: and my mesh-problems was gone. Before that noting except beams would mesh.

                • Meshing Parts
                  James Denney
                  Is anyone continuing to battle this problem? The mesher seems to have suddenly stopped working. I have a particular assembly that was successfully solid meshed several times previously over different studies, and I can no longer mesh the assembly. I tried creating simple parts and meshing them, but that is to no avail. I tried moving the simulation files directly under C: with no luck.

                  The message is always the same "Surface mesh successful, volume mesh failed. Reducing element size may help." In a couple of instances, a handful of parts would mesh successfully. I would reduce element size to try to capture the remaining parts, and all parts would fail.

                  Again, this is an assembly that I successfully meshed several times Monday and Tuesday, even this morning. I made some configuration changes, and suddenly I have difficulty meshing anything.

                  Any other ideas? I was trying to wrap up a project, and now I've come to a screeching halt.

                  UPDATE: I tested the assemble on my co-workers computer and it meshed and analyzed fine...just like it did previously on my machine. Could I have corrupted my Solidworks installation somehow?
                • Meshing Parts
                  Arun Prasad
                  Hey James, Even I am facing the facing problem as you. My Dell Precision (Intel Xeon) 8 GB ram could take any type of meshing. All of a sudden, the mesher seems to be not working. It is killing me. I thought there could be a problem with SW model..... even i get the same msg "Surface mesh successful, volume mesh failed. Reducing element size may help." Some body please help.... Currently using SP1.. Will a upgrade to SP2 solve the issue?
                    • Meshing Parts
                      James, you didn't say which version of SW you are using. I have seen a simular problem with SW2009 SP2.0. I had a part that the mesh failed for some odd reason and wouldn't mesh again no matter what I tried. I hunted up the Simulation files (I'm using C:\Simulation Results) deleted them and ran the mesh/study again without a problem. It seemed that something corrupted the Simulation files and remeshing didn't fix the problem.

                      A quick test would be to copy the study to a new study and try that. Make sure your Simulation results folder path isn't to long.
                        • Meshing Parts
                          Richard Obrien
                          I agree with Dan. Once a mesh fails, you can no longer mesh to the same folder. If you look in the folder and see a file named Fmesh.boiteb8, that is the culprit. Delete that file and you're good to go. Supposedly this whole pathname/mesh problem (SPR 462560) was fixed in SW2009 SP2...but maybe not.

                          Rick
                      • Meshing Parts
                        Mike Lowinske
                        I've encountered the same problem recently. Just randomly one day after running SW09 SP2 for like 3 months I could no longer perform a solid mesh on ANYTHING. Beam mesh and shell mesh work fine. But solid...forget about it. I uninstalled SW and put it back on (just the original SP0) and still the same problem. Any thoughts?
                          • Meshing Parts
                            Ian Hogg
                            Look to see if there is a file "Fmesh.bb" in the directory where the model is. If it's there, delete it and then try meshing it.

                            I had an issue like this some time ago, and I believe that this temporary file was the culprit. Normally it appears and dissappears without any issue.

                            Ian
                            • Meshing Parts
                              Mike, check your Study Properties, where is the Results folder? If it is buried down in something like c:\documents and settings\"user name"\local*****\******* change it to something short like c:\simulation results. I straightened it out once but after installing SP2.0 somehow it got changed back.
                            • Meshing Parts
                              Mike Lowinske
                              I had my simulation folder buried a ways down in my Docs like you said Daniel. No Fmesh.bb was located in that though. I actually found an FMesh file in C:\Documents and Settings\Administrator\Local Settings\Temp though and deleted that. I also moved my simulation and modeling folders from being so buried in My Docs straight up to the C drive level. Seems to be working well now. So thanks for the advice. I'll let you know if it breaks again.
                                • Meshing Parts
                                  James Denney
                                  Thanks, folks...great respones! I am using 2009 SP2.0. I'll be trying some of these suggestions and will report back with, hopefully, positive results.

                                  UPDATE: Yep, deleting any FMesh.* files and relocating Simulation files to a folder directly under C: did the trick. Thanks to everyone for the help
                                    • Meshing Parts
                                      Travis Morris
                                      For the most part everything that everyone has posted is the same thing that is happening to me. I have an asm of our floor steel that I am trying to mesh and run, I try and mesh and it starts to go then the "Mesh Progress" window pops up and starts to run thru the Evaluation Geometry (which it checks off) and Processing Boundary (also checked off) once it gets to creating mesh it kicks me completely out of SW. I have run the study on these floor steels prior to getting my upgraded computer, everything meshed and ran fine. On my old computer I had SW 08 and now I have SW 09 2.1 64 bit. I have tried the above suggestions to no avail. Any other ideas?

                                      Thanks
                                  • Meshing Parts
                                    Edward Wagner
                                    I had the same meshing problem (sw2009 sp2.1) - suddenly nothing meshed on a previously stable assembly, parts would not mesh individually. "Fmesh" was the culprit, also I moved all referenced files to the directory my assembly was in. Took care of the problem. Thanks, guys.