4 Replies Latest reply on Jan 15, 2018 9:22 AM by Yuri Lucchini

    DXF/DWG quality export issue

    Yuri Lucchini

      Greetings all,

       

      I have a problem regarding the export of a sketch from a part (selecting the face I want to export) and its conversion in DXF/DWG files.

      As you can see from the attached image, there is no way the final exported result can be the same of the initial one just selected, one click ahead. I presume it is clearly a discretization issue of Solidworks. I've tried to change the options for the DXF/DWG drawings as well as the curvature and refinement image's option, but nothing worked. Does anybody else noticed this problem or knows how to fix it?

       

      Best regards,

      Yuri

        • Re: DXF/DWG quality export issue
          Elmar Klammer

          Hi Yuri,

           

          Check your AutoCAD setting.

           

            • Re: DXF/DWG quality export issue
              Yuri Lucchini

              Thanks, Elmar.

               

              I tried to apply your hint in my final dxf, but nothing changed.

              I mean that the polylines remained splines instead of coming back to be circles, and many of them are really not useful to create a mechanical ground piece from the sketch.

               

              It is like if Solidworks itself discretize the DXF in a lower level of details the design I provide and I am unable to improve this discretization level. Perhaps it is a bug of Solidworks, with a feature to improve the details of a exported DXF that has to be implemented in a future release. However, at the moment, I don't seek a possible solution to my problem.

               

              Best Regards,

              Yuri

                • Re: DXF/DWG quality export issue
                  Elmar Klammer

                  Hi Yuri,

                   

                  Some trouble shooting steps...if you want you can upload the file or portion of it.

                   

                  When you export the face check your settings. See if High quality dwg is selected. The setting for polylines can also contribute.

                  If that does not work, then make a 1:1 drawing and export the drawing sheet itself. See if you get better results.

                  I remember that SW at some point uses the default drawing template in the back ground in order to produce the "dxf from face".

                  So if your template has low resolution settings (image quality, dxf settings) then that can be the cause.