AnsweredAssumed Answered

2018 SP0.1 Web2

Question asked by Martin Solem on Jan 9, 2018
Latest reply on Nov 27, 2018 by Bryan Riley

Hey forum,

 

I have a problem running 2018 SP0.1 Web2 on a new Windows Server 2016 virtual machine. Everything looks good, IIS is fine, i can access <webserver> but when i try to access <webserver>\SOLIDWORKSPDM (default) application pool, my browser just freezes, and on the server-side, the process w3wp.exe is using 97-100% CPU. The same thing happens if i try browsing on the server.

Installation runs fine, files are in place, local view is in place, the whole thing is set up by the book and i have spent hours troubleshooting what causes this. Local client works fine, all users that i have tested have logged into the local vault view first. Registry looks OK. All rights to folders and the application pools has ben cross-checked countless times, firewall is shut off. I am at a dead end. I have also tried creating a new application pool, and even tried to remove and reinstall Web2 and IIS7.

As a last resort i have set up a brand new 2016 server, which has only IIS and Web2 files installed, but i'm getting the exact same errors and behavior.

There is nothing in the PDM Client log, but this from the Event Viewer:

 

This appears when i kill the w3wp.exe process:

 

A process serving application pool 'SOLIDWORKS PDM Web2' suffered a fatal communication error with the Windows Process Activation Service. The process id was '3660'. The data field contains the error number.

Event ID: 5011

-Reported from WAS

 

Sometimes an error has been logged, right before i kill the w3wp.exe process, saying something like:

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

{D63B10C5-BB46-4990-A94F-E40B9D520160}

and APPID

{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}

to the user CCS-WEB-02\Administrator SID (S-1-5-21-1124329904-2597292670-2506141146-500) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

-Reported from DistributedCOM

 

I think have managed to fix these by adjusting Launch and Activation permissions in DCOMConfig, they belong to "Runtime broker" and there was another too, with just some Application ID.

 

 

I am now on my 3rd webserver, and they are all acting the same way. Something is dead wrong here, and it could easily be me, but i cannot see what it is.

 

Has anyone deployed Web2 successfully on a Win Server 2016, and/or is anyone aware of something the installation manual doesn't cover in Win Server 2016?

 

 

Kind regards,

Martin

Outcomes