4 Replies Latest reply on Jan 5, 2018 6:44 AM by Grant Kirkland

    File explorer variables do not match data cards

    Grant Kirkland

      My file explorer variable "ItemNumber" is not matching the variable shown in the part or drawing data card.

       

      Part and drawing: 1-0048046 (this is correct)

      file explorer: 048044 (this is incorrect and I have no idea where it is coming form)

       

      Has anyone encountered this?

       

        • Re: File explorer variables do not match data cards
          Josh Hixon

          You have two different configurations selected on your data cards, that could be part of it.

          The other thing I would look at is if your data card variables have the slddrw extension added in them as it is only the drawing that seems to be off. Hope this helps.

            • Re: File explorer variables do not match data cards
              Grant Kirkland

              I don't believe it's a mismatching configuration issue. The @ configuration drawing should show the 00 configuration model variables.

              I do have the slddrw extension listed. This doesn't happen with new drawings. Only migrated drawing it seems.

                • Re: File explorer variables do not match data cards
                  Josh Hixon

                  We have had similar issues, but not quite the same. Our issue was that we have a name field that reads from the File Name; gets input as $PRP:"SW-File Name" in the custom property. when we migrated from PDM workgroup, some files had the name value overridden with the value of that instead of the coding. I don't think you are having the same issue though. It may be possible that there is an old reference in the drawing that is broken, so if you say renamed an old file to get the new one, the drawing may somehow be referencing the old file. If you look at your custom properties for your Drawing, does the Item Number show up as correct? If not, try to tell your sheet to reference a specific drawing view, and see if that makes everything right.

                    • Re: File explorer variables do not match data cards
                      Grant Kirkland

                      Our VAR figured it out, and it sounds like you're on the right track. Our old "ItemNumber" serial number generator was creating variables for drawing cards AND part/assembly cards. On some old cards apparently the search column is pulling variables from old versions.

                       

                      I believe that particular model P-36247-00 was on version 16/16 but "048044" was an ItemNumber variable value from version 3/16.

                       

                      Checking "Look for variables in given list of configurations" fixed it. I have no idea what we would do it we didn't have consistent configuration names. Maybe SW should look into a "Look for variables in latest version" setting instead...