11 Replies Latest reply on Jan 4, 2018 1:27 AM by Deepak Gupta

    Can't float a part or add new parts in an assembly

    Kyle Foster

      Honestly I think I broke my Solidworks 2017 when I tried converting a big assembly file from Autodesk to Solidworks as ever since I've done that my assembly has not worked the same. Basically the issue I am having is when I insert a part into an assembly for the first time it is fixed (as it should be) but when I try to float it to move it there is no float option. On top of this I cannot insert additional or copy/past objects into the assembly and I get this error "Drag and Drop of imported components are not allowed". The part is by no means an elaborate one. I have attached the part file, assembly file, and screenshots galore.

       

      Things I have tried:

           - Right click the part and try to customize menu to make float visible (see screen shot)

           - Deleting my assembly template, loading an old assembly, deleting all parts and saving the base as the new template

           - I can insert assemblies into an assembly and move those around but this is not ideal