4 Replies Latest reply on Dec 19, 2017 10:02 AM by Ryan Dark

    2017-2018 Installation bug on HP Spectre

    Martin Manriquez-Castillo

      I have been having trouble installing Solidworks 2017-2018 from the SolidWorks Community download that university provides for my team. Upon downloading the installation manager I keep getting a shrunken buggy screen. I have gone through most common solutions that I could find; downloading Windows 10 pro, deleting previous existing files of SolidWorks, Troubleshooting the application and changing settings. I either get "This version of Solidworks is not compatible with Windows XP"  or The compatibility mode says that the Solidworks 2017-2018 runs on Windows 8. No one on my team has encountered this problem and I seem to be the only one.

      I'm attaching the pictures to the screens that I am getting.

      Thank you for the help.

        • Re: 2017-2018 Installation bug on HP Spectre
          Ryan Dark

          Hi Martin,

          It seems like you have a few things going on at once here.  The easiest one to check and fix is probably the one you call "Evidence-3" and "Evidence-4".  This one would be caused if either your "setup.exe" file or "sldim.exe" files were set to run in Windows compatibility mode.  The way to fix this is to go to each of these relative folders...

           

          <installation_root_folder>\setup.exe

          <installation_root_folder>\sldim\sldim.exe

           

          ...right click on each of these .EXE files then go to 'Properties'.  Once in the Properties dialog go to the 'Compatibility' tab and make sure the "Run this program in compatibility mode for:" option is disabled like this:

          Once you have disabled this setting for both .EXE files the warning about the program not being supported on Windows XP should go away.

           

          Next, "Evidence 2" would seem to show that you have a 4K monitor items in the OS set to be enlarged.  To fix that you would run a search in your Windows Start menu for "Make text and other items larger or smaller".  This search should reveal a display setting in your OS like shown below.  You likely do not have your OS set to "Smaller - 100% (default)" which the SOLIDWORKS Installation Manager tends to work best with.  Set this setting back to 100% then logout/login to your user account.  Most of your OS will likely look different but you should now be able to run the SOLIDWORKS Installation Manager without everything being enlarged beyond the borders of the window.