0 Replies Latest reply on Nov 23, 2017 11:57 PM by Keval Doshi

    Error while remote executing a standalone application using the solidworks API

    Keval Doshi

      Hi all,

       

      I have developed a standalone C# application using the Solidworks API to convert a part file to step. This works fine on the system I had developed it. Now I need to execute this remotely, ie. the users should be able to convert the file without having to login to the server, possibly from their own systems.

       

      1. Is it okay to do this without having to license the application on the user's system. I think it is, based on this - API Development without Solidworks

       

      2. The application that I developed works like this

       

      dotnet.exe myApp.dll

       

      It works fine when executed on the system. For remote execution, I use the Powershell Invoke-Command cmdlet. But while doing this I get the following error:

       

      System.Runtime.InteropServices.COMException: Retrieving the COM class factory for component with CLSID {D66FBAAE-4150-402F-8581-75D1652D696A} failed due to the following error: 80080005 Server execution failed (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)). at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor)

      at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark) at System.Activator.CreateInstance(Type type, Boolean nonPublic) at System.Activator.CreateInstance(Type type)

       

      I have tried a few solutions on the net as changing the target platform of C# app to x86 but none of them worked.

       

      I am completely new to C# application development and this might not be the right platform to ask this question, but any help on how do I go about doing this would be appreciated.