3 Replies Latest reply on Jan 13, 2018 2:03 PM by J. Mather

    I cannot get Solidworks to to load, all I get is a blank installation manager popup.

    Michael McCormick

        • Re: I cannot get Solidworks to to load, all I get is a blank installation manager popup.
          Jim Wilkinson

          hi Michael,


          See the More like this links on the bottom right of this post, or do a search in the forum for it like this:



          I am guessing you will find a solution in one of those posts.




          • Re: I cannot get Solidworks to to load, all I get is a blank installation manager popup.
            John Kay

            I was having the same issue with SW 2017 Student, most of the answers I found were to unblock the installation file, or IE browser settings. I finally emailed support, and the email I got back solved my problem.

            Please follow the below troubleshooting tips to resolve the problem related to blank installation manager:


            1. A.            When the installation files are downloaded and extracted it is possible that Windows will block the HTML files and scripting that creates the user interface for the Installation Manager. This results in the Installation Manager not displaying any options and showing a white screen.


            To correct this issue, the files for the Installation Manager will need to be unblocked.

            Navigate to the <SOLIDWORKS Download>\sldim\lang\english\HTML folder that was extracted from the download.

            Right click on a file found in the folder and select Properties.

            On the General tab select the ‘Unblock’ option.

            Do this for every file in this folder. The list of files should include the following:

            1. frameset.html
            2. framesetstartup.html
            3. header.html
            4. imfunc.js
            5. navpanestartup.html
            6. sldim.css




            1. B.            In most of the cases, resetting all Internet options to default fixes this issue.

            Once the Internet Browser options are set to default, close the Internet browser and re-launch the SolidWorks Installation Manager.

            Reset Internet explorer to default settings:

                    a.    In the IE browser > Tools > Internet Options > Advanced and

            click “Restore advanced settings”

                    b.    Still on the same tab click “Reset”

                    c.    Close browser and restart it.


            1. C.            Set Internet Explorer as default browser:

            Please go to Control Panel > Default programs > Set Default programs > Select “Internet Explorer” under program list and Select “Choose defaults for this program”

            Ensure that everything is selected as shown in attached image. If not, please select them to enable and then try.

            However if the problem remains it has been observed that the presence of other web browsers (e.g. Mozilla Firefox®, Google Chrome™) can cause problems if they are set as the default browser.  Set Internet Explorer as your default browser. Try temporarily removing other browsers and performing a clean install of Internet Explorer.


            1. D.            If you still face the issue try the following :

            Delete HTML folder  available under C:\Users\<username>\AppData\Roaming\SolidWorks\Installation Manager Data\<SolidWorks version>\lang\english\ To navigate to this location type %appdata% at Start > RUN and press enter to go SolidWorks folder. Under SolidWorks folder, you will find a folder Installation Manager Data under this folder go to SolidWorks version folder > lang > english> HTML and delete the HTML folder  then re-launch the SolidWorks Installation Manager.

            1. E.            In some cases this has been cause by an incorrect registry key in the following location:



            The subfolders of this key should only have numbers for their names.  If a subfolder is name anything other than a number, (such as a superscript L), then delete that key and restart the Installation Manager. This issue has mainly been seen on the Windows 7 x64 operating system.


            To check and delete the above mentioned folders Please follow the below


            1. 1.Go to Start > Type “regedit” (without quotes) and then press enter.
            2. 2.This will launch registry editor.
            3. 3.In the left side pane in registry editor, Double click on HKEY_CURRENT_USER to expand it further.
            4. 4.Similarly expand Software > Microsoft > Windows > CurrentVersion  > Internet Settings > Zones 5.Check the sub folders of Zones.

            It should have all the folders name with numeric value. If it has any folder which has some other name, Delete that folder. See attached image 'Regedit' for reference.

            1. 6.After deleting the folder/folders. Launch the Installation Manager again.

            (sorry about the "A." in front of each section, I couldn't fix the formatting) I did each step in the order that was sent, mine was finally fixed when I did Step D, deleting the HTML folder. Good luck!