AnsweredAssumed Answered

Installation error 1722 on DraftSight 2018 SP0

Question asked by Kalle Mikael on Nov 19, 2017
Latest reply on Jun 20, 2018 by Brad Huitt

I for a long time had DraftSight free version installed on a laptop.
I have lost the use of the laptop and wanted to install DS on my desktop Windows 8.1 Pro system.

I accepted the version offered on the web page which was 2018 SP0 Windows 32bit which matches my OS.

Download was fine. 
On install I receive the same installer error (1722) each time. I tried to run directly from Download directory, no joy, closed all other applications, no joy, tried with administrator privileges, no joy and then moved file to documents folder and ran installer with administrator privileges and still no joy.
Each time the install seems to proceed fine with unpacking, licence selection (free) and acceptance and then the progress bars work through to what seems to be the end (UPDATE: I moved the error dialog out of the way and saw the last progres bar was only at about 15%, others had run to completion) and then an error window pops up on the installer.  Click OK and it rolls back everything as before.  I have found one other used on a French blog that mentioned a similar error with no solution but very little else relating to my problem.

 

It mentions register_FXVistaPreviewDll at some uncertain location (the popup error has inadequate information even for a psychic person) and that's it.

 

This is not a Licence registration problem as the program has yet to complete the installation process but somehow related to DLL registration in the registry I surmise.

 

Is there a way to manually guide the installation process?

Can I find the missing file and save it in the expected place and "register" it in advance so the installer will be happy?

Is there an obvious reason why this might be happening?

UPDATE:   
I can locate the .CAB file during the install process and make a copy and extract the problem DLL. I placed an advance copy in %PROGRAMFILES%\Dassault Systemes\DraftSight\bin\ all lowercase and also in the camel case as it generates during the install.  No difference and it deletes it with the other files on exit.  I tried to register it as a DLL using the command "%windir%\System32\regsvr32.exe /i FxVistaPreview.dll" when in the \bin directory running CMD as administrator.  It gave an error about the file not being suitable as a DLL or something but not sure if I was doing something else wrong.

 

Can a corrupt CAB file be hiding inside the instalation EXE?  I would hope not but downloading it again may not provide extra information.

 

 

DraftSight 2018 SP0 error.jpg

 

Message was edited by: Kalle Mikael

Outcomes