7 Replies Latest reply on Nov 14, 2017 11:46 AM by Jim Wilkinson

    Disable "Open Documents" browser

    Richard K.

      TLDR: Is there a way to disable the "Open Documents browser" that pops up when you press CTRL+TAB?

       

      When I press CTRL+TAB to cycle between documents, Solidworks brings up a little window called the "Open Documents browser".  It's kind of like the one Windows brings up when you hit ALT+TAB.  Unfortunately the browser is a little laggy.  Often times, it hasn't come up by the time I finish releasing the CTRL and TAB keys.  When that happens, my keystroke gets "swallowed" and the documents don't switch.  I have to try again, but slower.

       

      I'm hoping disabling that unnecessary window will help Solidworks keep up with me.

        • Re: Disable "Open Documents" browser
          Jim Wilkinson

          Hi Richard,

           

          What version are you using? This should not be happening. If you just flick Ctrl+tab, the dialog should not come up at all and the documents should just switch. The dialog should only come up if you continue holding the Ctrl tab.

           

          Thanks,

          Jim

            • Re: Disable "Open Documents" browser
              Richard K.

              2017 SP3 x64

               

              Hmm, maybe I'm not letting go of CTRL quick enough after releasing TAB.  The window comes up about a quarter to half second after the tab key is depressed.

               

              Thanks for responding so fast.  I'll try to glean some more information next time it happens.  (Really I was just hoping there might be a way to disable the dialog to either see if it helps or rule it out as the cause of my keystroke being missed).

              • Re: Disable "Open Documents" browser
                Dan Pihlaja

                Jim Wilkinson  wrote:

                 

                Hi Richard,

                 

                What version are you using? This should not be happening. If you just flick Ctrl+tab, the dialog should not come up at all and the documents should just switch. The dialog should only come up if you continue holding the Ctrl tab.

                 

                Thanks,

                Jim

                 

                Hrmm, it seems to be a little "flakey".  I am using SW 2015 SP5 on Windows 10.

                 

                What I mean by that, is that the time it takes between "flicking" CTRL TAB and Holding down CTRL TAB seems to be very small....so small that I can't tell the difference.  See the attached video.

                 

                In the video, you can see where I hold down CTRL TAB and where I try to "flick" it.  You will notice that sometimes the Dialog will pop up briefly, which means that I must have accidentally entered the "hold down" threshold.

                  • Re: Disable "Open Documents" browser
                    Jim Wilkinson

                    Dan Pihlaja wrote:

                     

                     

                    In the video, you can see where I hold down CTRL TAB and where I try to "flick" it. You will notice that sometimes the Dialog will pop up briefly, which means that I must have accidentally entered the "hold down" threshold.

                    Hi Dan,

                     

                    Right, you probably went past the threshold, but either way, the switch happened and was very fast even when the dialog comes up.

                    I haven't seen a case like Richard mentions where the dialog coming up is slow and "eats" the keystroke so the switch doesn't actually happen.

                    I just played around with it trying to reproduce it and the only behavior I have found that I *think* may be what Richard is seeing is if I push and hold the ctrl+tab for a bit longer than a flick. Then what happens is the tab key is auto-repeating which cycles through the open documents in the dialog that comes up (this is the same behavior as seen if you press ALT+tab and hold both keys). So to see this, if only two documents are open, I push and hold Ctrl+Tab for a long time, you can see it going back and forth between the two documents. If I happen to let go the keys while on the first document instead of the second document, then the document won't switch. So, the timing of longer than a flick can run into the same issue (if the tab key auto-repeats). I don't believe we have any control over the auto-repeat timing since this is an OS function.

                     

                    BTW, in answer to the original question, no there is no way to turn the dialog off. However, even without it, if Ctrl+tab is to switch between multiple documents (more than 2) then this problem I describe above would happen even without the dialog since the tab key would still auto-repeat to switch between them, you just wouldn't be able to visualize it.

                     

                    Thanks,

                    Jim

                • Re: Disable "Open Documents" browser
                  David Matula

                  you may want to look at cleaning up some stuff too to increase performance of the computer.