AnsweredAssumed Answered

Model hidden/obscured when rendering with depth of field enabled

Question asked by Christopher Thorn on Nov 9, 2017
Latest reply on Nov 11, 2017 by Christopher Thorn

I'm trying to render a model using PhotoView 360 in SolidWorks 2017 SP3.0 and I need to do it with depth of field enabled. However, when depth of field is enabled, my model disappears or gets obscured somehow. Some shadows are visible, but the model geometry is not. If I disable depth of field in the camera settings, it renders just fine.

 

In the examples below I'm just using a couple of hollow cylinders with their bottom faces mated to the XZ plane. I hid the model I actually want to render and tried it out with these simple cylinders just to see if it was the original model that was causing the issue, but the issue remains.

 

This is the saved camera view:

 

 

This is the preview window:

 

 

Here are my camera settings:

 

 

Here are how the camera and focus planes are positioned in the model:

 

 

Here are my scene settings:

 

 

I've tried adjusting the position and distance between the focus planes, the size of the blue/magenta view rectangle, whether the view rectangle is in front of or behind the focus plane(s), etc... Nothing fixes the issue.

 

Any help is greatly appreciated!

 

Chris

Outcomes