34 Replies Latest reply on Sep 26, 2018 11:03 AM by Gene Gillott

    Draftsight 2018 SP0 - Crashing (Never allowing Activation.).

    William Scott

      Hello,

       

      I have downloaded DS 18 - SP0 and upon installing the app starts and closes. I am not able to find anything regarding an error in the eventlog and have tried to install it multiple times. Being that this is a rebuild of my laptop I was expecting to get the activation popup being the first time, but I never get it. I would like to get the app installed as I use it to tinker around for home projects.

        • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
          William Scott

          Well, I would have to say if I cant get an answer to a simple question like this, Why would I consider purchasing Pro?

          I understand this is a forum but there are moderators that work for 3DS, so not getting a response to remediate a issue like this is surprising.

          • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
            Gary Kephart

            All I had to do to make it work was to change the properties of the program to "run as administrator" and then it behaved as expected. Hopefully this will work for others as well!

            • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
              Mike Kehrli

              I am having the same issue.  I had originally had 2017 version, and it crashed every time I tried to activate it.  I didn't see the hotfix post for 2017 versions.  I went ahead and installed the 2018 version.  Since then it still crashes in the same way.  I've uninstalled Draftsight completely and re-installed it.  I have it set to run as administrator whenever it starts.  But it still crashes when I try to activate it.  I'm able to put in all the information.  My email twice, and all the data about country, state, job title, etc.  When I click on the "activate" button, it just flashes once and crashes.  No email arrives.

               

              Has anyone solved this for 2018 SP0?

              • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                Michael Lord

                Just had the same experience with DraftSight 2018 SP0 and Windows 10 (latest update)

                DraftSight 2016 would not open with the latest version of Windows 10. So I unistalled and installed 2018 SP0

                At first it would not install as it keep telling me that I did not have permission for C:\ProgramData\Dassault Systemes\DraftSight\addinConfigs

                I first had to change ownership from SYSTEM to myself despite me being an Administrator

                Then it point black refused to Activate!  Have been down this route before!

                 

                It was solved by opening a dxf file from File Explorer.  Which as it was opening DraftSight it brought up the Activation registration.  Filled it in and received the activation email! 

                • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                  Mhmd Nopy

                  put this in txt file then rename it to .bat

                  @echo off

                  setlocal

                  set KEY=HKCU\Software\SWActivation\K2

                  set V=Software/office/editor/versionII/Ready

                  set Vcopy=Software/office/editor/versionII/Loop

                  reg query "%KEY%" | findstr "%V%"

                  if %errorlevel% EQU 0 (

                  echo La valeur a copier %V% existe

                  goto suite) ELSE echo La valeur a copier %V% n existe pas

                  goto fin

                  :suite

                  for /f "tokens=3* delims= " %%k in ('reg query "%KEY%" /v %V% ^| findstr "%V%"') do set drc=%%k

                  echo cle a copier : %drc%

                  reg query "%KEY%" | findstr "%Vcopy%"

                  if %errorlevel% EQU 1 (

                  echo La valeur de destination %Vcopy% va etre creer

                  goto traitement) ELSE echo La valeur de destination %Vcopy% existe deja

                  goto fin

                  :traitement

                  @echo TRAITEMENT

                  REG ADD "%KEY%" /v %Vcopy% /t REG_SZ /d %drc%

                  goto fin2

                  :fin

                  @echo ARRET : RIEN A ETE FAIT

                  :fin2

                  pause

                  ............

                  work 4 me

                  Pér.Inf. Iso: DraftSight 2017 SP3 ne démarre pas, ne s'active pas, on ne recoit pas l'email d'activation

                  • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                    Aaron Wolfe

                    I have what sounds like the same problem.  I click to open the program, the splash screen comes up, I then get "DraftSight has stopped working"  and the program is closed.  I have searched for a solution, but am at a loss.  Old solutions don't seem to apply to this problem.  I am trying to migrate to a new computer, and I loaded DraftSight 2018 downloaded from the website.

                      • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                        Aaron Wolfe

                        In my case I was able to activate it when I installed it a week ago on my new computer.  I went to use it today and now I just get "DraftSight has stopped working".

                          • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                            Rick McDonald

                            The only problem I have had since I got mine activated was that a couple weeks ago (actually Nov. 8th) Windows did an update and my User Account Control went screwy and kept asking me if I would allow Solidworks or Draftsight to run (like I had my user settings set too high for my permission levels).  I did a restore point to the previous day and they ran fine but a couple days later on another update it did it again and killed my last restore point that worked (I didn't have my settings to allow enough restore points to be retained).

                            I finally fixed it by setting each Icon, Program and link to these to be full admin rights with read and write ability for my account as well as my user (even though my user account has full admin rights).  I finally got them working this way.

                            This does not sound like your problem though.

                            I assume you have done a full power down restart of your computer - have you tried to reinstall?

                          • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                            Aaron Wolfe

                            I discovered the problem on my system.  I use a USB 3.0 port expander when I am using my laptop at my desk.  It uses a DisplayLink (DL) driver that runs the second monitor.  If I unplug the port expander and just run DraftSight only on my laptop screen, DraftSight works fine.  Also, if I run the second monitor using an HDMI cable plugged directly into my laptop, DraftSight works fine.  And finally, if I have it set to "Duplicate displays" it works fine.  Now some details... If I have my laptop screen set as my "Main Display" DraftSight will open.  I can even drag it over to my DL monitor.  But the drawing area does not paint on the DL monitor, either it is black and nothing shows up when you draw in it, or it shows artifacts of the side panes if they are moved.  If I use it on the laptop screen, it works fine.  This is the first program for me that has not worked on the DL monitor.  Is there some way to submit a bug report?  I have already sent a request to DL.  Not sure which side needs to fix the problem, DraftSight or DisplayLink or maybe both.  I know there are many USB 3.0 expanders that us the DL drivers.

                          • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                            Dan Schleicher

                            William,

                                        Please look at Mr. McDonald's replies! He was also on the other discussions on how to activate Draftsight.

                            • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                              John Crist

                              I just loaded 2018 but it could only run about 20 seconds without crashing, and it wouldn't save.  I loaded the SolidWorks approved video driver (Quadro K620, Windows 10) and that completely fixed both problems.

                              At work my ProE Creo  (Win 7) crashed every hour or two.  I replaced the non-CAD video card with a Quadro K2000 and it stopped crashing.

                              • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                                Jean-Philippe Schwob

                                Hello,

                                On many occasions, we have been faced with the problem of activating Dassault's Draftsight software.

                                Here is a procedure that will allow you to activate a user's license.

                                Jean-Philippe

                                 

                                Installed version : 2018SP1 64 bits


                                # Connect with the profile of the user who wants to use Draftsight

                                # Start installing Draftsight using the "Run As Admin" function

                                # Select, free license

                                # Click on "Done" and then on "No thanks"

                                # Go to the folder

                                # Run the Draftsight.exe program as an administrator

                                # Click on "Activate"

                                # Enter twice the email of the user who wants to use Draftsight. The other 3 fields to fill in are of no

                                importance.

                                # Open the Draftsight User Mail and wait for the email to be received for activation

                                # Click on the link

                                If everything goes as planned, the app will open a web page to tell you that everything is over, but

                                kidney will not work. Whenever you want to use Draftsight, the application opens and closes

                                instantly


                                Procedure to correct the problem


                                # Start the Regedit program as administrator

                                # Go to HKLM\SOFTWARE\MICROSOFT\WINDOWS NT\Current Version\ProfileList

                                # Identify the ID of the administrator used to install Draftsight and the ID of the user who wants to

                                use Draftsight.


                                Example

                                Admin user : S-1-5-21-4270634972-2877105811-2816753613-1635

                                Draftsight user : S-1-5-21-4270634972-2877105811-2816753613-18733


                                # Go to HKEY_USERS\< ID of the admin >\SOFTWARE

                                # Select SWActivation puis clic droit> then right click, export

                                # Save the file as c: \ temp

                                # Edit the file with NOTEPAD and replace

                                S-1-5-21-4270634972-2877105811-2816753613-1635

                                By

                                S-1-5-21-4270634972-2877105811-2816753613-18733

                                 

                                Example

                                Windows Registry Editor Version 5.00

                                [HKEY_USERS\S-1-5-21-4270634972-2877105811-2816753613-18733\Software\SWActivation]

                                [HKEY_USERS\S-1-5-21-4270634972-2877105811-2816753613-18733\Software\SWActivation\K2]

                                "Software/office/editor/versionII/Ready"="yuPb+l+egKbzWGEyN62JIg=="

                                "Software/office/editor/versionII/guid"="{49ea71f4-333e-4d91-8623-65d3f2db15b7}"

                                "Software/office/editor/versionII/Loop"="yuPb+l+egKbzWGEyN62JIko="

                                "Software/office/editor/versionII/Green"="yuPb+l+egKbzWGEyN62JIg=="

                                "Software/office/editor/versionII/PrevRenewal"="yuPb+l+egKbzWGEyN62JIvA0CsneAQ=="

                                "Software/office/editor/versionII/Renewal"="nrx/80JUX/7zWGEyN62JIoA="

                                [HKEY_USERS\S-1-5-21-4270634972-2877105811-2816753613-

                                18733\Software\SWActivation\K2\Software/office/editor/versionII/UserRegData]

                                "User_email"="xxxxxxxxxx@sogefigroup.com"


                                # Save the file

                                # Go to REGEDIT and do : File – Import and select the saved file

                                 

                                 

                                Start DRAFTSIGHT

                                  • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                                    Paul Hetherington

                                    HI, just renamed SWActivation to SWActivation_old and reinstalled. Worked a treat.

                                      • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                                        Rick McDonald

                                        That seems it would indicate it was something in the registry that was somehow set incorrectly by the earlier attempts and your effectively purged it and did a clean install.  It seems that most of the problems were from permissions (probably networks settings not accepting the https://www.3ds.com (or similar) ). 

                                        Good that you got it running.

                                          • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                                            Paul Hetherington

                                            Hi Rick,

                                            The https://www.3ds.com was on my trusted list already.

                                              • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                                                Rick McDonald

                                                It would be interesting and possibly a key to the problem if you could compare the section of your registry for Draftsight and see what differences there are.

                                                I would expect you would find at least a few.

                                                That information could be very helpful in creating another solution and could be sent to the Draftsight team as Solidworks and help them make the installer correct that for the future.

                                                If you get the chance and can post the differences that you find (excluding any serial numbers or license information that is specific to you)?

                                                  • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                                                    Paul Hetherington

                                                    Here it is...SWActivation_old is the original that was renamed by me, SWActivation is the newly installed key that worked.

                                                    As has been mentioned before, the original problem occurred after opening Draftsight maybe 6 times, then it delayed at the flash screen, finally asking me to re register. On clicking OK, the program closes.

                                                    Reg entries below...

                                                     

                                                     

                                                    Windows Registry Editor Version 5.00

                                                     

                                                    [HKEY_USERS\S-1-5-21-1075075338-2603872991-1059393414-1109\Software\SWActivation]

                                                     

                                                    [HKEY_USERS\S-1-5-21-1075075338-2603872991-1059393414-1109\Software\SWActivation\K2]

                                                    "Software/office/editor/versionII/Ready"="a6cU0AvRsn8VbqU="

                                                    "Software/office/editor/versionII/guid"="{140bbf8e-cd51-4acc-b394-aa8bf58f0172}"

                                                    "Software/office/editor/versionII/Loop"="a6cU0AvRsn8VbqU="

                                                    "Software/office/editor/versionII/Green"="a6cU0AvRsn8VbqU="

                                                    "Software/office/editor/versionII/PrevRenewal"="a6cU0AvRsn8VbqU="

                                                    "Software/office/editor/versionII/Renewal"="Gd1l7RdNFMwVbqU="

                                                     

                                                    Windows Registry Editor Version 5.00

                                                     

                                                    [HKEY_USERS\S-1-5-21-1075075338-2603872991-1059393414-1109\Software\SWActivation_old]

                                                     

                                                    [HKEY_USERS\S-1-5-21-1075075338-2603872991-1059393414-1109\Software\SWActivation_old\K2]

                                                    "Software/office/editor/versionII/Ready"="Y0sXMZxYkbgVbqU="

                                                    "Software/office/editor/versionII/guid"="{0b076efa-58ef-46a3-b46b-85c6ce02a5c3}"

                                                    "Software/office/editor/versionII/Loop"="Y0sXMZxYkbgVbqU="

                                                    "Software/office/editor/versionII/Green"="Y0sXMZxYkbgVbqU="

                                                    "Software/office/editor/versionII/PrevRenewal"="Y0sXMZxYkbgVbqU="

                                                    "Software/office/editor/versionII/Renewal"="SkyGYVn5VHIVbqU="

                                          • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                                            Brad Huitt

                                            While this problem seems to be a little different than mine, I wanted to post my solution for those who might still be having trouble and looking for other things to try and fix their Draftsight 2018 problems.

                                             

                                            My issue involved Draftsight not being able to install.  It would crash when it tried to register a DLL with regsvr32.

                                             

                                            Noneof Yourbussines posted a solution on another thread about installing the 2015 C++ redistributables, but I had both of the VS 2015 C++ redistributables installed already.  Repairing them didn't work either.  After re-evaluating the error message (like Kalle Mikael the error message said it was unable to register a DLL using regsvr32) I deduced that maybe there was a problem with the x86 (32bit) version of the VS 2015 C++ redistributables.  So I

                                            1. downloaded the VS 2015 C++ Redistributable package from Microsoft download
                                            2. then I uninstalled the x86 version
                                            3. rebooted
                                            4. then re-installed it.

                                            After that I was able to install Draftsight 2018 SP2 without any problems, as well as some other software that was giving me fits!

                                            • Re: Draftsight 2018 SP0 - Crashing (Never allowing Activation.).
                                              Gene Gillott

                                              I have always had issues with Draftsight.  The most recent was this week when I had to re-activate.  I did this and for the remainder of the day it worked OK.  However, the following day, I would only get the initial "flash" on the screen and then nothing.  I tried a number of times to re-install and had no luck.

                                              I then removed all traces of the program using RevoUninstaller and did a re-install but again no luck.  At that point I gave up.

                                              Today I tried one more desperate attempt to install but this time the installer detected the previous installation and removed it.  I then continued with the new install and was able to complete it and do the registration.

                                              From what I can see, the removal routines provided by DraftSight appear to remove everything and allow for a clean install.