8 Replies Latest reply on Oct 8, 2017 5:06 PM by Ryan Dark

    Database not found

    Sarvesh Ambekar

      Dear Community members/Support group,

      I am facing a strange problem with Solidworks. For past couple of weeks I am working on an analysis and everything was working fine till today. Today, when I open the same analysis and try to refine mesh in certain area and run the simulation with improved mesh. Analysis started correctly, mesh generation was successful, contacts were established, stiffness matrix was also applied & when the contact solution was suppose to start then I started getting an error 'Database not found'.

      I tried various options,

      1. Tried to copy the existing analysis with new name and run the simulation but the same error appeared.
      2. Analysis Properties > results folder shows correct part where all the models are located.
      3. Enough space exists in the specified drive.

      Does anyone has any idea about how to solve this issue.

      Thanking you all in anticipation.

      Best Regards

      Sarvesh

        • Re: Database not found
          Sarvesh Ambekar

          Dear Members/Support Group,

          I could see following error for the analysis when I refined mesh in certain areas of interest for better results.

          If I run the analysis with less finer mesh, I see no issues.

          Does anyone has any information about this issue and how can it be fixed. I searched the knowledge base but could not find any suitable explaination.

          Many thanks!

          Best Regards

          Sarvesh

          • Re: Database not found
            Ryan Dark

            Hi Sarvesh,

            Where are you storing/accessing the CAD files from as your run this analysis on them?

              • Re: Database not found
                Sarvesh Ambekar

                Hi Ryan,

                Firstly, thanks for your interest to support me with my queries.

                I am using an external portable SSD device to store/access my files. All analysis files will be stored at the same location under a subfolder 'analysis' in the same parent directory which holds the models.

                I guess, this setting is available with solidworks under Simulation > Options.

                  • Re: Database not found
                    Ryan Dark

                    Sarvash,

                    I think you are looking at the source of your problem today.  Move all your files off the external drive and into a folder on your C-drive then run the analysis from that local copy of your files.  Does the database missing error persist in that setup?

                      • Re: Database not found
                        Sarvesh Ambekar

                        Dear Ryan,

                        Thanks for the advice. As per your advice I copied the model on my Local Disk (D drive) & performed analysis again. Unfortunately, it didn't fix the problem.

                        In this case, I didn't apply the fine mesh to the specified area but I apply the fine mesh to the whole model. I know it is not the right approach but it was more convinient. I see now following error.

                        followed by error

                        Let's hope we get some solution for it issue.

                          • Re: Database not found
                            Ryan Dark

                            Sarvesh,

                            If you right click the study name at the top of the boundary tree and go to 'Properties' is the result folder for your study pointed to the new local C-drive folder or back to your external drive?

                             

                              • Re: Database not found
                                Sarvesh Ambekar

                                Hi Ryan,

                                I tried your suggetion but had the same results.

                                May be the problem is somewhere else. The simulation works perferetly in every storage situation but when mesh is set up for finer mode the issue starts to pop up.

                                Many thanks for your informative tips and guidance.

                                  • Re: Database not found
                                    Ryan Dark

                                    Sarvesh,

                                    It seems very odd that just reducing the mesh element size would set off an error like this.  Could you either attach the file set to this forum post or email me (it's in my profile) a .ZIP of your file set for me to just run through a test solve on this end and see what happens?