7 Replies Latest reply on Oct 3, 2017 2:14 PM by Ryan Dark

    Solidworks won't recognize propellers in flow simulation

    Lance Plater

      Hi everyone,

       

      I was trying to simulate flow around a ducted fan. However, when I generated the flow trajectories, the arrows went directly through the propellers, instead of around them as you'd expect (see pic below).

       

      https://flic.kr/p/Y1ZmZg

       

      Additionally, I got a very low force value (0.1N) as if the propellers weren't even there. I'm wondering if this has to do with the rotating region, which I choose as a solid cylinder instead of the actual propeller. For some reason SW wouldn't allow me to select the propellers for the rotating region.

       

      https://flic.kr/p/YZtDgb

       

      I was wondering if this had something to do with the "disable solid components" in the rotating region GUI (see pic above). How can I get solidworks to recognize the propellers as the rotating region?

        • Re: Solidworks won't recognize propellers in flow simulation
          Ryan Dark

          Hi Lance,

          From the images you have linked the setup seems fine.  You do want to create a large cylindrical boss to select for the rotating region and not select the propellers themselves.

           

          Typically have the flow not interact with bodies is because they are either made as surfaces instead of solids or the components are disabled under 'Component Control' (found by right clicking 'Input Data' in the Flow Project tree and going to 'Component Control').  These would make the geometry invisible to the flow.  Given that the FeatureManager shows all bodies as solid it could be that the propeller bodies have become disabled somehow.  You would want to check under 'Component Control'.

           

          Also the "Disable solid components" option being selected and grayed out is just kind of an oddity in my opinion.  Its purpose is to disable the cylindrical body you selected for the rotating region within 'Component Control' so it does not accidentally act as a giant cork in your analysis.  It seems more informative than optional.  Here's a small snip of its definition from the help files:

          The Disable solid components option is always selected and allows you to disable the component in the Component Control, if you specify local rotating region in a fluid region defined by a model component.