3 Replies Latest reply on Jul 10, 2018 7:05 PM by John Finch

    "Failed to create temporary file..." - Two hard drives. Any solution?

    John Finch

      Whenever I run simulations, I sometimes get problems with SolidWorks being able to find directories. Other errors I get are...

       

      "Failed to create temporary file. Please change Simulation work directory."

       

       

      "Mesh information not available"

       

      "Data not found"

       

      I have an SSD and a standard Hard drive on my computer. The system defaults to trying to save SolidWorks on the SSD, but I tried to change the installation location to the hard drive since it is larger. I'm wondering if this created the problem. I originally had SolidWorks installed on the SSD, and then uninstalled it and put it on the hard drive. (I also have two version of SolidWorks, SW 2016-2017 and SW 2017-2018)

       

      Thanks,

      J

        • Re: "Failed to create temporary file..." - Two hard drives. Any solution?
          Ryan Dark

          Hi John,

          All three of the errors you are listing have to do with write access to the simulation results directory.  If you right click on the study name at the top of its boundary tree and go to 'Properties' where is the 'Results Folder' pointing on your machine?  If this is a location on one of your local drives it is not deep concern.  However, if it points somewhere else like a network drive or external drive you might expect to see intermittent write access issues like you have here.  If it is listing a local path to one of your on-board drives then you would want to look at something that could inhibit write access to temporary files such as when the Simulation working directory is placed in a PDM vault folder or when antivirus software interferes with the creation of these temporary files.

          • Re: "Failed to create temporary file..." - Two hard drives. Any solution?
            Jeffrey Desorbo

            Hi John,

             

            Was this ever resolved?

             

            I am experiencing the same behavior, only I am using Solidworks over a "Virtual Learning Environment" (VLE) through my university. Unfortunately I cannot access any local files, and everything is mapped to a network drive automatically.

              • Re: "Failed to create temporary file..." - Two hard drives. Any solution?
                John Finch

                Jeffrey,

                 

                Turns out the issue was not having two hard drives at all, as I was thinking when I originally posted this. I ended up discovering that the root of the problem was that I have Google Drive set up to sync my files to the cloud. What this means, is that I had files saving locally on my computer, and whenever a file was added/modified, Google Drive would automatically start uploading that to the cloud (same thing happens in reverse - if a file is modified in the cloud or on a different device, it would update/add the local file as well).

                 

                My fix: Before I run a simulation, I pause the Syncing to Google Drive. This solved my issue. What is this VLE like at your school? Is it a school server, or a program like Box, OneDrive or Google Drive?

                 

                I know that at my school, everything operated out of the network drive EXCEPT the DESKTOP. The desktop was local. Therefore, a potential fix is saving your file to the DESKTOP, and running the simulation on that file. The trick is, you have to make sure you are running the simulation from the file that you have on the desktop. It is not enough to just copy the file to the desktop and still open the file that exists on the network (I've seen many people do this, and have done it myself without realizing). This solution worked at my school.

                 

                Hope this helps!

                John