11 Replies Latest reply on Oct 3, 2017 2:29 PM by Dave Krum

    Any way to "hide" these annoying relation icons in Hole Wizard?

    Dave Krum

      I'm sure there is alot out on the web about trying to hide the relation icons that automatically appear when trying to pick an entity but nothing that I've read successfully works consistently.  My main annoyance is when using the Hole Wizard.  In order to fully define a linear pattern (for instance), I need to dimension vertically between two holes in the pattern below then make give both of them a vertical relation.  I usually don't have an issue with holes, but now I have slots and simply cannot get them pattern fully defined.  I have relations turned off in the HUD.  I've even gone as far as suppressing the relation but now it turns black and I still cannot pick the slot centerpoint beneath the icon to dimension.  These icons just appear when trying to do stuff and you cannot pick the sketch points beneath them unless I'm missing something.  I'm on SW2015.  I tried using filters but had no work either.  Any ideas would be much appreciated.

       

      P.S.  I have undefined points in a sketch set to the purple color instead of the default blue.  Basically I cannot add relations to entities once the relation icon covers up the defining point to select it)

       

      Can dimension vertically between holes:

      But now when I try to give both of them a vertical relation, I cannot pick the centerpoints cuz the software picks the pattern relation icons instead since they appear once I select the first hole (I cannot select the first hole but while holding ctrl and select the 2nd hole, the pattern icons appear so the second slot centerpoint cannot be selected):

        • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
          Dave Krum

          J. Mather, not sure how but it appears your response was deleted?  Not sure how that happened.  Here was my response:

           

          Good morning and thanx for the response.  I usually don't use construction lines when patterning a hole or slot with Hole Wizard, I'll usually just place the first hole in position then select it and choose linear pattern then once the new holes appear, I'll just fully define the pattern with usually a linear dimension and relation with no construction lines (not that if that is the conventional way but I've been doing it like that for years).  I'll try your suggestion and sees if that helps in selecting stuff.  I have the below setting turned off and they won't appear until an entity is selected, but then the relation icons appear for every entity involved in the relation and they appear right over top of the point I need to pick:

            • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
              J. Mather

              Dave Krum wrote:

              .... they won't appear until an entity is selected, but then the relation icons appear for every entity involved in the relation and they appear right over top of the point I need to pick:

              I deleted my previous response after testing with a pattern.

              If you had attached your *.sldprt file I would have tested using your actual file and understood the issue right from the start.

              Use Construction Lines would be my revised solution.  Funny thing is - I use more construction lines now than I did back in the last century on the drawing board when we are always admonished by the instructor, "Don't delete err, erase your construction lines."

              If that doesn't work - can you attach your *.sldprt file here?

              (I like pretty pictures, but I like geometry files even more - I guess that is why I use SolidWorks rather than Photoshop.)

                • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
                  Dave Krum

                  Sure.  Here it is.  I checked again (also where Dan suggested) and both are turned off. In any case, here is my file.  Very simple sheet metal part.  Didn't try "select other" but that HAS worked nicely for me in the past for other sketching options.  Will have to try.  Thanks.

                    • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
                      J. Mather

                      I tested before adding these construction lines and Perpendicular relation.

                      Either way - the Relation glyph did not appear right overtop of the sketch points in my test.

                       

                      Sketch Relation Glyphs.PNG

                       

                      I tested both with Edit Sketch and with Edit Feature and going to the placement tab.

                       

                      Edit Feature.PNG

                      • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
                        Dan Pihlaja

                        Dave Krum wrote:

                         

                        and both are turned off.

                        They are actually both the same command, just can be found in two different locations.  I was showing you both locations.

                         

                        Dave Krum wrote:

                         

                        Didn't try "select other" but that HAS worked nicely for me in the past for other sketching options.

                        Something like this has happened to me in the past, and I have used select other to get around it.  Another thing to note, is that, if you box select the area, it will select both the point and the relation.  Then if you select another piece of geometry, Solidworks will recognize that you want to add a relation and will give you the correct pop up.

                         

                        Like J. Mather, I currently can't repeat it for some reason, though.  Edit: I also am on SW 2015, SP5

                          • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
                            Dave Krum

                            I think the "select other" is a good option for me plus the box select.  I didn't think you could box select an entity but didn't test.  I am outta here for the day guys.  Thanks for the help.  Appreciate it.  Have a good weekend. 

                            p.s. I'm on SP5 SW2015 also.  Maybe there's an option I'm not aware of for placing the relations icons on center / offset / etc.

                            • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
                              Dave Krum

                              "Select Other" while holding down CTRL to select the 2nd entity centerpoint works perfect!  This is the only thing that seems to work.  Not sure why the relation icon/glyph is offset from the centerpoint on both yours and J. Mather's version (this would be my preference as well but I looked in options and nothing jumped out at me as to the positioning preference of it).  Its clear though that on both of your copies, the icon appears on screen offset from the centerpoint and on my copy, the glyph is being located on dead center as seen from pics above.  But by using "selecting other" then choosing the "point" underneath the relation glyph, all works well as a work-around.  Thanks for the help.

                      • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
                        Dan Pihlaja

                        Yes.  Use this:

                        or this:

                         

                         

                         

                         

                        The other option is to RMB on the area and use "Select Other"

                        • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
                          Kevin Pymm

                          Dave,

                           

                          My Relation icons are offset & never appear over the top of the selection.

                           

                            • Re: Any way to "hide" these annoying relation icons in Hole Wizard?
                              Dave Krum

                              Just want to add one more thing to this thread regarding these "glyphs" being dropped dead center on top of centerpoints, whereas for others who replied on this thread about their software having them offset.  Couldn't figure out why this could be happening on my version which is also SW2015 SP5.  Well, I had to close SW in order to run #TASK which I always use to create dxf files of all of my parts (just a habit, not sure if it has to be closed).  Upon reloading SW for more parts, the relation glyphs/icons are now OFFSET as they should be.  Go figure.  So I guess "when in doubt" just close and restart lol.