5 Replies Latest reply on Nov 2, 2017 8:57 AM by Jim Wilkinson

    SoldWorks Performance Issues

    Eric Hamm

      I am trying to use solidworks on the New Surface Pro(2017)  i7  8gb RAM and I am running into some really weird performance issues.  I can barely make files.  It struggles to make the first sketch.  The client freezes up and crashes. Once i get into the sketch I can work without any issues but when i try to go back and edit them solidworks freezes again and crashes.  What I find weirdest is Solidworks is only using 200mb of ram at that point there is 4 more gb to use and the there is plenty cpu left.  Open GL box is checked and I couldn't uncheck it if I tried.  None of the safe modes made a difference.  Any other cad I run (Inventor and Fusion) work fine.

        • Re: SoldWorks Performance Issues
          Anna Wood

          To toggle the Use OpenGL check box, have SolidWorks running Without any files open.

           

          Turn off RealView, Shadows, etc.  May want to turn down the Anti-Aliasing options as well.

           

          What video card is in the machine?  May look into a different video card driver.

          • Re: SoldWorks Performance Issues
            Kevin Berni

            Hi Eric,

            There are some tips listed for Surface Book on the video card testing page.  Also, please check Windows update to make sure that you have the latest graphics card driver.  There were some issues with GeForce GTX drivers late last year and early this year: Slow performance with GTX960m in SW2016

             

            So you might want to see about manually downloading from the NVIDIA website and updating it that way.

            • Re: SoldWorks Performance Issues
              Todd Burrough

              Hi Eric

               

              same issue and the open gl tick box is the solution but as you may have found most people don't read what you wrote 'surface pro 2017' and start to talk to you about drivers that arn't what your machine has 

               

              i've been hunting for the solution for this for a while now as well - i've got rx safe mode to work and narrowed it down the the open gl tick box but as you have noticed it is greyed out when in normal mode - it would be good if someone from solidworks team actually replied with a solution as i see it as a very simple single option but teh grey out makes in very hard to sort

               

              hoping a driver update will fix it but don't hold my breath

               

              T

                • Re: SoldWorks Performance Issues
                  Jim Wilkinson

                  Todd Burrough wrote:

                   

                  Hi Eric

                   

                  same issue and the open gl tick box is the solution but as you may have found most people don't read what you wrote 'surface pro 2017' and start to talk to you about drivers that arn't what your machine has

                   

                  i've been hunting for the solution for this for a while now as well - i've got rx safe mode to work and narrowed it down the the open gl tick box but as you have noticed it is greyed out when in normal mode - it would be good if someone from solidworks team actually replied with a solution as i see it as a very simple single option but teh grey out makes in very hard to sort

                   

                  hoping a driver update will fix it but don't hold my breath

                   

                  T

                  Hi Todd,

                   

                  The Software OpenGL option can only be changed with no SOLIDWORKS documents open as documented in these help topics:

                  2018 SOLIDWORKS Help - Performance Options

                  2018 SOLIDWORKS Help - Graphics Adapters and Drivers

                   

                  Also, did you go to the tips link that Kevin mentioned above for some additional settings that may help?

                   

                  Thanks,

                  Jim