17 Replies Latest reply on Nov 5, 2018 8:25 AM by Patrick Junker

    Draftsight activation problems on Mac

    Steve Kale

      Hi.  I cannot activate the latest version of Draftsight.  Despite repeated attempts I simply never receive an email.  I've never had this problem before but have recently moved from London to Miami.  I've read here and elsewhere that numerous other people have had the same issue.  However, most of the workarounds suggested have involved Windows users.  I've read that Firewalls may be related to the issue. However I have no firewalls operating and have had the same problem when I completely bypass my fixed wire network and connect to the Internet by hot spotting via my iPhone and wireless carrier.  I am stumped as to what to try next and would appreciate any suggestions.  When I can't even activate and learn to use the free version it doesn't inspire me to pay for a professional license.

        • Re: Draftsight activation problems on Mac
          Adam Hartles

          Steve, have you tried the SP0 install and hotfix route- seems to be solving the majority of issues

          1. Login to the PC as a local administrator


          1. Go to Windows Control Panel > Programs and Features . Right Click on  DraftSight product and select Uninstall


          1. Rename the DraftSight folder in the paths shown below to something like DraftSight_OLD

          a.        C:\Program Files\Dassault Systemes\DraftSight folder (to ex. DraftSight_OLD)

          b.        C:\ProgramData\Dassault Systemes\DraftSight (to ex. DraftSight_OLD)

          c.        C:\Users\AppData\Roaming\DraftSight (to ex. DraftSight_OLD)


          Note: AppData might be hidden and not show in Windows Explorer. The easiest way to get to that   folder location is by typing %Appdata% in the Windows Explorer Address Bar and pressing enter.


          4.  Clean up registry by deleting DraftSight registry key folders

          HKEY_CURRENT_USER > Software > Dassault Systemes > DraftSight

          HKEY_CURRENT_USER > Software > SWActivation


          Install SP0 and the hotfix under a local admin account, if DraftSight launches choose CANCEL at activation screen

          Reboot and login under normal user account and launch DraftSight to activate.


          DraftSight SP0 and Hotfix Link



          • Re: Draftsight activation problems on Mac
            Steve Kale

            Who is "we"?


            i perfectly understand DS not wanting to provide technical support for the use of a free product. But I do not understand why they wish to maintain a blatant deterrent to sales. A free ir trial version of software is normally designed to entice sale. Here it is acting in entirely the opposite manner. They would be better off withdrawing the free version entirely. Why offer an enticement which just punches people in the face?

            • Re: Draftsight activation problems on Mac
              Stephen Grupinski

              I had the same problem on Sierra and High Sierra.   Finally got it working by deleting the DraftSight.app file from the Applications folder.   Just re-installing did not work.  Once the app was deleted the OS treated it as a new install and brought up the "unidentified developer" warning.  After allowing it in the Security & Privacy section of the control panel, Draftsight started and brought up the same activation dialog, but this time it worked!   My guess is it has something to do with the way the OS treats apps from un-identified developers and blocks internet access.  Sure would be nice if Dassault would use a Developer ID certificate or put it in the App Store.  I know it is free, but if you can't use it you aren't going to upgrade.

                • Re: Draftsight activation problems on Mac
                  Kaylen Eckert

                  I am having the same problem.  I've spent about six hours trying to figure it out and still no luck.  I have a Mac and I have now installed High Sierra to see if it will work.  I did the complete delete of the app and reinstall, still it shuts down every time I try to activate.  This is amazingly frustrating.  Please fix this Solidworks Draftsight people!  I found this software amazingly perfect for what I needed when I drew a house renovation that I was working on two years ago.  I am very willing to pay money for a working Mac version of Draftsight, but these kinks need to be worked out. 


                  Also, last version wouldn't allow me to pdf properly.  It would show it correctly in pdf preview, then it would pdf as a small scale of the drawing in the corner of the page.  The Version that was able to be downloaded two years ago worked great.  Maybe just give the option of using that one again...?

                • Re: Draftsight activation problems on Mac
                  Vo Gon

                  Mac user here and I have the same problem.  Here is the only workaround I have found so far.:


                  Launch DS and fill out the activation window.  Click Activate. Click the following pop up activation window, and then DS will unexpectedly quit.  Relaunch, and this time when the very first activation alert window pops up, just close it using the top left close box, and the application then starts as usual.


                  I am using DraftSight 2017 SP3 on Mac OS 10.11.6


                  Good luck.


                  PS:  DraftSight, why would I shell out $99.00/year for software riddled with bugs.  For example the copy/paste keyboard commands are not implemented. I have to select a block of text and right click to select copy or paste from the contextual menu.

                    • Re: Draftsight activation problems on Mac
                      Vo Gon

                      UPDATE: Above fix only worked a few times and then the original problem returned. 


                      However, I had forgotten that I originally installed DS on a different iMac in my office, and went over to that computer, downloaded and installed the current update, ran the reactivation routine, and now DS works on both my desktop and my laptop.  It appears the activation code is associated with the first computer on which I installed DS.


                      If you have DS installed on more than one Mac make sure they are all updated at the same time.




                      Vo Gon

                    • Re: Draftsight activation problems on Mac
                      Wendy Wang

                      I created an account just to post this because it was so frustrating.


                      I got it to work by doing the following:


                      1. Uninstall DraftSight via AppCleaner (so that all files are absolutely gone).

                      2. Reinstall with the dmg file.

                      3. Once it is installed, go to Finder, not any other program, right click to open, and it will ask you to confirm you want to allow this app. Click yes. Then it could activate fine.


                      My own analysis is that when I first tried to install it , I opened it with another file opener (Path Finder if you are curious), and I got the "unidentified developer" dialog, and I think from that moment, that my computer blocked DraftSight from all outgoing connections as a protective measure or something.


                      Oh well hope this helps someone!

                        • Re: Draftsight activation problems on Mac
                          Steve Kale

                          Yes!!  App Cleaner did the job.  Thanks Wendy!

                          • Re: Draftsight activation problems on Mac
                            Patrick Junker

                            Hi Wendy,


                            Like you I just created an account in this forum to share my surprisingly simple solution, which finally solved the problem for me. I found that out already a few months ago when your entry was not yet posted. I just came back today to also share my solution. Maybe your method could have helped, too, but what did the trick for me was much simpler than that - though it might have some relation to your method in wiping out every trace DraftSight has left on the file system using AppCleaner.


                            I had all the described issues with the re-appearing activation dialog on every start and non of the described solutions worked for me. This is what finally did the trick (believe it or not!):


                            I just used a different email address in the activation dialog and - bam - DraftSight immediately returned to normal operation!


                            I'm lead believe that using a new email address might have somehow re-initiated a really new and fresh activation process, whereas the previous attempts using my previously used email address got DraftSight in sort of an error reading the past activation. But that's just an assumption.


                            Maybe this helps someone.


                            Best Regards