14 Replies Latest reply on Jan 23, 2009 5:26 PM by Dale Dunn

    Units of Drawing vs components

    John Williamson
      I keep getting the message:

      Solidworks has detected that the units of the drawing differ from some of the components in the assembly. This can affect the display of notes or table cells linked to custom properties assigned to those componnents in Lightweight. Resolving these components can be time consuming but will update the text correctly. Would you like to resolve these components?

      Anyways, I keep clicking Don't ask me again and hitting yes and the damn thing comes back every time. How can I get rid of these messages?
        • This reply has been hidden. This can happen if the message has been hidden by a moderator, or has been reported as abusive.
          • Units of Drawing vs components
            Anna Wood
            John,

            Yes, I am seeing the same thing on assembly drawings. Click the message box, don't show again and it shows again.

            Also the assembly drawings are opening up lightweight. I never, ever, ever work with lightweight anything. Resolve the drawing and save and it will open up lightweight again. I have my system options set to fully resolve everything, always.

            Exit SW, re-open same drawing and the units of drawings and assemblies message box, that I dismissed once already, shows up again with the model in lightweight mode.

            SW has messed up something on the SP2.0 release.

            Cheers,



              • Units of Drawing vs components
                Mike McLaughlin
                Anna, I'm running SP0 until tomorrow and it behaves the same for me.
                • Units of Drawing vs components
                  Kevin Quigley
                  Its the same in SP) and SP1 Anna. Lightweight drawing views seems to be the new resolved! So THATS how they speed up the drawings 5x!! I'm so used to just right clicking the top of the drawing sheet and choosing "set lightweight to resolved" (or whatever the message is - I'm not at a SW machine now) I've probably not picked up on some new preference setting introduced in SW2009 that has been called something really obvious like "drawing acceleration" or "quick display" or whatever term marketing have dreamt up

                  Anna Wood wrote:

                   

                  Also the assembly drawings are opening up lightweight. I never, ever, ever work with lightweight anything. Resolve the drawing and save and it will open up lightweight again. I have my system options set to fully resolve everything, always.

                  SW has messed up something on the SP2.0 release.

                  Cheers,

                    • Units of Drawing vs components
                      Anna Wood
                      Kevin,

                      That is exactly what I am thinking too. So that is how SW speeded up drawings. :-)

                      Sigh.....
                        • Units of Drawing vs components
                          John Williamson
                          Yeah, I read something to the effect that resolved drawings are now effectively "obsolete" with 2009, so they removed the lightweight option to force the decision. Unfortunate for some of us, for sure. Does anyone have an idea on a specific type of drawing view that would cause the problem? The error message implies it has to do with components that use different units, such as metric instead of english. I have parts that use both in all of my assemblies, so does this mean I will have to redraw all of my drawings in "pure" 2009? Horrible, horrible thought.
                            • Units of Drawing vs components
                              Richard Doyle
                              Hi John,
                              That comes from the "What's New in 2009", but is a little vague. I'm trying to get some clarification on it, and I'll report back here.

                              As for the dialog box issue, there is an SPR written for it.

                              From the Knowledge Base:
                              SPR 461651: Don't ask me again for the message '...detected that the units of the drawing differ from....' is not stored when SolidWorks restarts.
                              Don't ask me again for the message "...detected that the units of the drawing differ from...." is not stored when SolidWorks restarts.
                      • Units of Drawing vs components
                        John Williamson
                        Well, Bobby, if you could enlighten us morons, I'd appreciate it.
                      • Units of Drawing vs components
                        Kevin Quigley
                        Same here. Happens on all files that started in previous versions but seems to be OK on "pure" SW2009 versions. As you said John, I'm sure Bobby could tell us all what we are doing wrong
                        • Units of Drawing vs components
                          John Williamson
                          I am wondering if perhaps I would have had this problem before if I had ever loaded my assembly drawings lightweight. This always causes me so many problems that I never did. Now that I am forced to, I need to figure out a workaround. I have been having all kinds of awesome crashes. The coolest one is when I close the program, it crashes after it saves my files (thank god) about 90% of the time. No clue what is causing this either.