8 Replies Latest reply on Jul 17, 2018 1:22 AM by Phil Ponka

    "Hidden" components in drawing views

    Colin Parkhurst
      Like many others, I am constantly dealing with graphics issues since upgrading to SW2009. I have learned to deal with it and am, for the most part, able to work around these problems. There is one issue that I am having with a few of my assembly drawings that I have not been able to easily work around. When I open an some existing drawings, certain components and subassemblies do not show up in the drawing views. In the design tree it shows the parts in question as being hidden, but when I open the assembly itself, all of the parts are visible. I have gone through all of my system options and settings as well those of the parts and I have not been able to find out why this is happening. This includes ensuring that "hide components on view creation" is not checked. I have tried opening the files on other machines here and have the same issue, so I am led to believe that the drawing file is somehow corrupt, possibly due to the conversion to SW2009.
      The only way I have been able to correct this issue is by replacing the affected drawing view (basically redrawing everything), stretching what should be a 10 minute task into a few hours of work. After these views are redrawn, there is no longer a problem with these components. Because the problem is not recurring and is limited to only a handful of drawings (that I know of), I do not find this to be an urgent matter. I am simply reaching out to see if anyone else has had a similar problem or has any ideas to make my life a little easier.
      Although I am posting this with zero hope of a solution, any input on this matter is greatly appreciated.

      Colin
        • "Hidden
          Allen Koszi Jr
          no, solution, but some input....

          this is not limited to 09.
          i had this problem in 08 with large assembly drawings, and thier respective section and detail views.
            • "Hidden
              Joel Bickel
              Items could be hidden in a particular view. Go into the tree of the drawing and look for parts/assemblies that are greyed out. I have seen some parts that are randomly hidden in a view.
                • "Hidden
                  Victor Sanchez
                  Try a force rebuild using "ctrl Q".
                    • "Hidden
                      Allen Koszi Jr
                      neither works, have tried.
                      as i'm sure Colin has. his post was pretty detailed.

                      what also doesn't work is right clicking on the view, Properties, Hide Items tab
                        • "Hidden
                          Charles Culp
                          The last time this came up, the problem was that there were additional display states that were active. So check and make sure that all the views have the display states that you are expecting.
                            • "Hidden
                              Colin Parkhurst
                              Al is right, I wish it were as simple as a rebuild or having the part hidden in certain views. Same goes for the references of the parts.
                              Charles, thank you so very much for the suggestion. I have checked the display states and it seems to be the issue. There are a few dozen different configurations for this assembly, and each has its own matching display state. In addition there are another few dozen display states (which are clearly unnecessary). But even when I select the appropriate display state, there are still missing components. I think this may take me going through every display state and matching them up. Not really saving me much time, but a great help nonetheless. It seems that the different configurations are not linked to specific display states as I feel they should be in this situation. I will continue to explore this and do my part to organize this assembly accordingly. At this point, I am fairly convinced that this is not due to an upgrade but rather a lack of consistency among the design team - an issue I don't even want to get started on.
                        • "Hidden
                          Did you check your drawing references? You may have to reestablish your relations of drawing/part references.
                      • Re: "Hidden" components in drawing views
                        Phil Ponka

                        Hey,

                         

                        2017 here

                         

                        I fixed the whited-out files not showing on the drawing by right clicking "drawing view- 'x'" in feature tree to properties, going to the "hide/show components" tab and selecting and deleting the components i wanted shown.

                         

                        the whited-out insignia denotes hidden-but-active apparently.