62 Replies Latest reply on Oct 19, 2017 3:25 PM by Rob Johnston

    Missing custom properties in part, assembly, and drawing files

    Matthew Perry

      Greetings,

       

      I've done my best to search through discussions to find an applicable solution but no luck.  If someone could help me or point me in the right direction it'd be greatly appreciated!!!

       

      My issue is this...I went to edit an assembly drawing today and noticed some of the custom properties were missing.  After some digging I found that custom property data was missing on several part and assembly files.  The weird thing is that some parts/assemblies have lost data while other parts/assemblies referenced in the same drawing have retained the data.  I only have 3 custom property tabs, one for each file type (part, assembly, and drawing) which are referenced by the respective file type templates.  I most recently tried to re-enter values into a custom property, ie "Part No." (see image below) but now the data won't store after I select Apply.

       

      Below is a screenshot of a part that lost data and a part the retained data.  The missing data appears to only be values/text I specifically enter in such as "Modeled By", "Part No.", "Finish", etc.  Also, custom property values that are missing in a part/assembly file are missing for all configurations within that part/assembly.

      Solutions I've tried but did not work

      1) Used the command "regsrv32" to fix the "sldpropertyhandler.dll" file - ran under Admin but no change

      2) Updated to SW 2017 SP03

      3) Restarting/shutting down (multiple times)

      4) Verified the Custom Property Tabs have Show on Configuration Specific Tab selected

      5) Verified correct file location target for Custome Properties under system properties

      6) Attempted to dettach and reattach custom property template in part file under (button to the right of "More Properties")

       

      Again, any help would be greatly appreciated.  I'm hoping there is some minor detail I've overlooked and all the lost data can be retreived.

       

      Thanks,
      Matt

       

      System:

      Running SW 2017 SP03 on Win 10 Pro