7 Replies Latest reply on Aug 5, 2017 1:15 PM by John Willett

    Simulation: "Select entity" Error

    John Willett

      What does this error message mean (running SW Premium 2017 SP3.0 under Windows 7 SP1):

      Cannot Change Gravity Direction.png

      The previous study ran successfully with gravity horizontal:

      Before Change Gravity Direction.png

      I copied that study and tried to change the direction of gravity.  The error was generated when I clicked the green check mark to accept the change. -- John Willett

        • Re: Simulation: "Select entity" Error
          John Willett

          Update:  There's even worse news than the above.  When I try to close the assembly, it wants to save multiple (presumed unchanged) parts.  When I tell it to save, it then wants to rebuild before save.  (This rebuild request happens even if I've just forced a manual rebuild!)  OK, so I rebuild and save.  When I next open the assembly, the same happens!

           

          Something is wrong with this assembly (on which I just ran a successful simulation), but how do I figure out what? -- John Willett

            • Re: Simulation: "Select entity" Error
              Siavash Khajehhasani

              If you could post your model, it would be helpful to find the cause of warning.

              As a suggestion: please try to select another plane from a component in the assembly or a face of a component to see if it happens again or not.

              Regarding the multiple rebuild concern, it comes from the CAD side and it is already being observed; please report it to your VAR.

                • Re: Simulation: "Select entity" Error
                  John Willett

                  Siavash -- Thanks for getting back.  Attached is the basic model with the multiple-rebuild problem and the first (working, although the run is very long) study.  I can duplicate the problem either by copying the study and then changing the gravity plane or even by just editing the existing study.  It doesn't seem to matter what plane I use.  Further, bringing up the edit window for gravity is very slow and operates very "klunky." -- John Willett

                    • Re: Simulation: "Select entity" Error
                      Siavash Khajehhasani

                      John,

                      This could be as a result of a corrupted file into your simulation setup or could be a bug which I would like to ask you to report it immediately to your VAR for further investigation. (I tested it both in 2017 SP.3 and SP.4)

                      The gravity and centrifugal loads cannot be defined in your simulation!

                      I'd like to thank you for sharing your model.

                      I definitely will keep an eye on this post and will continue investigating it.

                      Cheers,

                      -Siavash

                        • Re: Simulation: "Select entity" Error
                          John Willett

                          Siavash -- Thanks for your interest!

                           

                          >>This could be as a result of a corrupted file into your simulation setup or could be a bug which I would like to ask you to report it immediately to your VAR for further investigation. (I tested it both in 2017 SP.3 and SP.4)

                          The gravity and centrifugal loads cannot be defined in your simulation!<<

                           

                          I will report it and post back with any results.  From what you say, it might work to start a new simulation from scratch, using the same model.  Correct?

                           

                          >>Regarding the multiple rebuild concern, it comes from the CAD side and it is already being observed; please report it to your VAR.<<

                           

                          I have already reported that one.  I could re-create the entire model and simulation in 2016 SP5.0, but that would be a lot of work!  Do you think it would be a viable work-around for both problems? -- John Willett

                      • Re: Simulation: "Select entity" Error
                        John Willett

                        Siavash -- An update -- I just spoke to a tech at my VAR.  He says:

                         

                        1) The multiple-rebuild problem does not occur for him in 2017 SP4.0.  They supposedly fixed it in that SP.  I'll have to update and see for myself.

                         

                        2) There is a work-around for the gravity-direction problem that is described in SPR #: 724407.  Basically, open the gravity line in the feature mgr for editing and uncheck Symbol Settings/Show preview.  Then make the desired changes and save.  Then right-click on the same gravity line and set to Show.  The changed gravity direction now shows up (and I assume is recognized by the solvers -- haven't tried that yet either).

                         

                        I hope this helps a bit. -- John W.

                        • Re: Simulation: "Select entity" Error
                          John Willett

                          Siavash -- I last wrote:

                           

                          >>1) The multiple-rebuild problem does not occur for him in 2017 SP4.0.  They supposedly fixed it in that SP.  I'll have to update and see for myself.<<

                           

                          Updating to SP4.0 does not appear to resolve this problem.  Could you please refer me to the thread(s) in which it was discussed on the CAD side?  I'm not finding anything with a quick search. -- John Willett