3 Replies Latest reply on Aug 1, 2017 8:44 AM by Glenn Schroeder

    ICON needed for 'Enable Snapping' status

    Doug Barr

      I frequently turn on&off the setting to Enable Snapping in the Tools/Sketch Tools menu. Similarly I frequently use the setting Automatic Relations. There is an icon for Automatic Relations, and a 'status indicator' on the toolbar menu indicates whether it's set on or off. I'd like to have a similar toolbar menu icon for the Enable Snapping on/off status. I have assigned the letter 'E' to that command, but in order to enable or disable it, I have to either walk my way into settings, or test its status, and then turn it on or off with my E. Not ideal. Can an icon be created on the next SP? Thanks.

        • Re: ICON needed for 'Enable Snapping' status
          Glenn Schroeder

          Did you know that you can just hold down Ctrl while placing sketch entities?  That will disable snapping.  They're enabled again as soon as you release it.

            • Re: ICON needed for 'Enable Snapping' status
              Doug Barr

              I was not aware of that function.

              The reason I often need to turn Snapping off is so that when I'm dragging a 3d wireframe endpoint for repositioning, if I pass over another entity, it momentarily jumps to that entity's Z level, but doesn't return to the original Z level after passing it. So I disable snapping, and it ignores the 'new' Z level. Am I making sense?

               

              I will try your Ctrl method. Thanks.

                • Re: ICON needed for 'Enable Snapping' status
                  Glenn Schroeder

                  Doug Barr wrote:

                   

                  I was not aware of that function.

                  The reason I often need to turn Snapping off is so that when I'm dragging a 3d wireframe endpoint for repositioning, if I pass over another entity, it momentarily jumps to that entity's Z level, but doesn't return to the original Z level after passing it. So I disable snapping, and it ignores the 'new' Z level. Am I making sense?

                   

                  I will try your Ctrl method. Thanks.

                   

                  That makes perfect sense.  Holding down Ctrl should work beautifully.