4 Replies Latest reply on Sep 6, 2017 3:14 PM by Greg Welch

    Pack & Go Error

    Steve Kunz

      SolidWorks 2017 SP3 (Windows 10 Pro Ver 1703)

      Have have had very little success with the last few versions of SW being able to Check "Include Drawings" for "Pack & Go" operations. If I start with the Drawing to generate a Pack & Go the Tool brings itself, the Drawing File by default along with the parts and assemblies fine. Whenever I start a Pack & Go with an Assembly for example I typically get a SW crash in the Pack & Go menu directly or shortly after selecting "Include Drawings". If there are more then one Drawing File I am out of luck at this time to be able to collect all files using this process.

       

      Recently I did a full by the book "Clean Uninstall" and "Reinstall of SW 2017 SP3 to resolve this and a few other issues. Now when I select "Include Drawings" I receive a error dialog "An invalid argument was encountered" If anyone has had similar experiences or has any recommendations I would appreciate it. The "file" field area of the Pack & Go Menu then comes up empty, no crash this time but no "Pack & Go" Success either.

       

      SWInvalidArgumentDialog.jpg

        • Re: Pack & Go Error
          Salih Alani

          Hi Steve,

           

          this issue might be related to a widows profile , have you tried login to the same machine with different user , or if you do not have other user to login , try create a new windows profile and try test the same workflow to see if you can reproduce the same error.

           

          -Sal

          • Re: Pack & Go Error
            Greg Welch

            I have had a similar problem.  We recently switched from Windows 8 to Windows 10.  I still have access to a Windows 8 computer, but my main computer is Windows 10.  When I do a pack and go on my main computer, opening with an assembly, and then ask to have the drawings included, SolidWorks just locks up.  When I try the same assembly on a Windows 8 computer, there's no problem.

            • Re: Pack & Go Error
              Jeff Mowry

              What if you try this not from within SolidWorks, but from Windows Explorer?  Find your file, right click > SOLIDWORKS > Pack and Go...

               

              I had a problem similar to yours previously and this work-around did OK for me.