AnsweredAssumed Answered

BOM entries get removed when I select to use Document Name in Config manager

Question asked by Steve Krause on Jul 29, 2017
Latest reply on Jul 29, 2017 by Steve Krause

I have BOM on a drawing.  I notice that some of the items in the part number column are showing the configuration name, not the file name.  Those are parts that I have downloaded from places like McMaster where their parts set the name of the one config in the part to be their mcmaster part number.

 

So I've read the solution is to open the part.  Go to the Configuration Manager of that part.  Right click to select Properties and go to the section about BOM names and change it from config name to document name.  In my case the document name is the file name, which is the part number.  So I select document name from the three choice pulldown.  I save.  Go back to the assembly and save (probably don't have to save but I do), then I go to the drawing and look at the already created BOM and I see that the part has actually been removed from the BOM.  Not only did it not change the name from the mcmaster config name, it actually removed that part from the BOM.

 

I've also noticed that there is a check box in Configuation manager of the part that says "use in bill of materials" and it allows me to manually enter a name.  I have tried that too.  By default I think it is off.  I have tried it with the box checked and with it unchecked.

 

I've done this with three parts and each time I do it that part gets automatically removed from the BOM.  My BOM has gone done from having 24 rows of parts to 21 rows.

 

What is causing this?

Outcomes