0 Replies Latest reply on Jul 27, 2017 1:35 PM by Andrew Feiner

    Vault Assembly Problems

    Andrew Feiner

      I have a large assembly stored in the Workgroup PDM Vault for my company and every time I check out the assembly, there is one mate that claims that it is missing one mate entity. The design contracting firm my company works with says that when they open the assembly, there is no error. The mate entity is a face on a nut which is part of a multibody part. I have tried:

      • Changing the mate to a face or edge on a different part
      • Changing the mate to a different face or edge on the same part
      • Finding the “missing” face and fixing the mate
      • Opening the multibody part and selecting “edit feature” on the nut.
        • In the design tree, the sub-part causing the issues is listed as “PartNumber->?” sometimes with and sometimes without the question mark at the end
        • In this case, I receive a pop-up saying the part could not be found
        • If I instead right-click and select “edit in context” I am asked if I want to suppress the component or browse for the file. I browse for the file and select the proper file.
          • No mates within the multibody part show any errors (never did), but the design tree still gives it a weird name.
        • I check-in the multibody part to the vault and rebuild the assembly
      • Getting an original copy of the multibody part from our design contractors, saving it locally to my computer and making sure all of the sub-parts have no issues, and checking in this file to the vault to replace the one causing issues.

       

      All of these methods would “fix” the error in the assembly and I would check in the document to the vault and close the assembly, but when I check out the assembly again, the rebuild icon is on the assembly icon in the design tree and I click rebuild and the error returns. The last method on the list actually solved the problem for a while (2 days) but then the problem came back even though I did not check in any other revision of that multibody part or revert to a previous revision/check in a different version of the assembly. I made other changes and fixes to other parts of the assembly that stayed fixed when I re-opened it, so I am sure that the assembly was successfully saved and checked in and updated in the vault. I am at a loss to what is causing the problem, let alone how to resolve it. My company has had issues with our toolbox recently that may be the root of the issue, but I have a local copy of the nut in question and when I am asked to browse for the file (see above) I choose it, which resolves the problem until I check the assembly back out. Any ideas?