8 Replies Latest reply on Apr 20, 2018 11:21 AM by Andrew MacAluso

    Windows 10 Version 1703 Breaks SW Macros (VSTA DLL's)

    Robert Chase

      I've had a new Dell Precision Tower 3620 for about 4 months now. Very happy with how fast it is and I'm even liking Windows 10 (still has a few quirks, but the speed definitely outweigh any problems I've had so far). Anyways, It decided somehow to install the creators update 1703. After which SolidWorks would not run any custom macros that are saved as DLL's.

      Error_CannotOpenDLL.png

      I went to the install media and went to the prereqs folder. When I ran the VSTA install now everything is fixed. I opened my personal laptop (surface pro4) to see if it had the same issue, and yes since the update (a month prior) it couldn't run macros. I ran the VSTA install and again all is fixed. So I do not know the exact cause but if you are having trouble with macros after the 1703 windows 10 update run the VSTA installer and it should fix any issues with the macros not opening.

      VSTA_install.png

      VSTA_install_screen.png

      After running the install now in the programs and apps list it shows, it says it installed it during the update according to the date but prior to me running the install it was not in the list.

      programs list.PNG