2 Replies Latest reply on Jul 13, 2017 10:28 PM by Siavash Khajehhasani

    "Unable to open master control file"

    Theo Van Aert

      i wanted to do a static study of my assembly.
      But when i press run this study, i get the error above.

       

      I have tried doing the same simulation on a different pc. But it gave the same result.

       

      I have no idea how to fix it or where even to start looking for a fix.

      because after googling the error, it s still not realy clear what's wrong ..

        • Re: "Unable to open master control file"
          Ryan Dark

          Hi Theo,

          In the times I have seen this error it was caused either by a permission issue to the folder the simulation data was writing to, a network communication issue (if the files are stored on a network hard drive), or having foreign characters in the folder path the dates is writing to.

           

          So, my question would be, what is the exact folder path to the SOLIDWORKS cad files (and by extension the simulation results directory) that you are working on here?

          • Re: "Unable to open master control file"
            Siavash Khajehhasani

            Hi Theo,

            The error message is usually related to characters in the path, filename or study name which are not part of the computer's OS language (for instance, Chinese characters on a Japanese machine). This can happen when you are using files you didn't create yourself.
            Unsupported characters prevent the program from accessing and opening the files it needs to read, and in particular the Master Control file.
            In some instances, this error can appear if the program was not able to create the Master Control file for other reasons. Such can include:
            - You don't have the correct permissions to write to the results folder.
            - The disk is full
            - Other software interfering with one or more temporary files used by the solvers (security,
            anti-virus, backup/mirroring software, etc)

            Potential solution
            1. Check the path, filename and study name. Check the path to the results folder. Make sure that all the characters are supported by your operating system. If not or when in doubt, replace them with standard English characters.
            2. If this doesn't solve the problem, check where the SOLIDWORKS files and where the study's results folder are located. If the SOLIDWORKS files or the results folder are on the network, copy them to the local computer and run them there (making sure that the result folder is also local, and not on the network). Also, log in as the system/network administrator and run the analysis. You should not have any problems running studies when you are logged in as administrator.
            3. Make sure you have enough available space on the disk where you are writing the results
            4. To check whether other software interfering with one or more temporary files used by the solvers (security, anti-virus, backup/mirroring software, etc), disable them one by one and rerun the study.

            Cheers,

            - Siavash

            Ref: S051516