8 Replies Latest reply on Sep 18, 2018 2:51 PM by Emile Daoust

    selection cursor defaults to smart dimension, dimensions not visible

    Alperen Pala

      Hello,

       

      I have a problem when sketching.

      I am using solidworks 2016 education edition.

       

      Regardless of entering new sketch or editing existing ones, the default cursor is always smart dimension, and I cant select entities unless I have a selection filter.

       

      Any dimension I place with this default cursor is also invisible.
      Tried registry edits, restarting solidworks and my computer.
      Can not seem to solve this problem.
      Some people previoulsy have posted this problem but no definitive answer was give, also the threads are very old related to SW2011 and stuff, so I dont know if they are still relevant.
      Nonetheless I tried what was written but didnt help at all.

      I attached a gif of the problem.

      Other parts I have have the same problem, when editing at an assembly level, I get the same problem.

       

      Basically the plain selection cursor has somehow turned to the dimension cursor, and the dimensions I give are not visible for some reason.

       

       

       

       

       

       

      What should I do?