AnsweredAssumed Answered

Styles not showing up in composer player

Question asked by Willy Wonka on May 31, 2017

I've created a few different styles in Composer to use in my views/animation projects. When I open one of the project files up in the Composer Player on another computer, the font size and colors from the style are not correct. My computer is the only one with the full Composer license and the styles are saved to the default location Documents\SolidWorks Composer\User\Profiles on my machine. I need to be able to open the Composer project files on other machines with Composer Player and maintain the styles.

 

I tried to copy the styles to a folder in our vault so that they can be accessed by all of the Composer Player machines and then updated the DataPath.xml file on those computers to look to that vault location for the styles with a link like the following:

<DataPath.StyleList>

     <Path0 Value="conisio://vaultname/explore?projectid=856&documentid=45998&objecttype=1" Description="Shared Vault Styles"/>

</DataPath.StyleList>

That however resulted in the xml file becoming invalid. I don't remember the exact error but it said it was expecting a ; somewhere inside that conisio link where there shouldn't be.

 

Feeling that accessing styles saved to a Vault location was asking entirely too much of Composer, I then tried copying the styles to a folder on the Composer Player computer's local hard drive and update the DataPath.xml file to point to that local folder. That did not work either. Does anyone have any ideas advice for what I could be doing wrong?

 

Also I found it strange that one of the Composer Player computers opens the files with the correct colors for the style and just the font sizes are wrong and another computer opens it with both colors and font sizes being wrong.

Outcomes