AnsweredAssumed Answered

SolidWorks Addin not loading

Question asked by Richard Lessard on May 28, 2017
Latest reply on Aug 28, 2018 by Liu Xubo

I am developping an addin for SolidWorks.  The addin is now in production for a few months and works well on all computers except mine (development computer).  It was working before, but developping the last release, it doesn't work anymore. 

 

I can't find a decisive reason why it doesn't work anymore.  I moved the  development folder, but I also modified all the paths in the registry using regasm.exe.

 

  • I tried various version of my addin (registering, un-registering everytime with regasm.exe), including versions that are now in production (and working) on many other computers.
  • I cleared the registry related to the addin before re-registering it (using regedit).
  • I uninstalled and re-installed SW.
  • I tried to launch the addin in various ways (trough the addin manager, opening it with file open, etc.)

 

The problem is that I can't figure way to get closer to the problem...

  • There is no error message, the addin just doesn't load
  • I tried to launch in development mode from Visual Studio, using breakpoints as early as possible in the code, but it doesn't reach the breakpoints.

 

I am using Solidworks 2016 x64 / VisualStudio 2015 (VB.net)

 

Anybody have some tips / solutions to help me?  Thanks!!!!!

Outcomes