AnsweredAssumed Answered

settings

Question asked by Richard Dierks on May 2, 2017
Latest reply on May 3, 2017 by Glenn Schroeder

Hello,

I'm a one-seat home business user, no network or permissions constraints.  I just did a clean install of Windows 10 Pro on my Puget Systems Echo Pro because System Restore had stopped working.

 

Since reinstalling SolidWorks 2015 SP5, I've tried what I can to get my settings reinstalled, including the Copy Settings Wizard and manually copying the swsettings.sldreg file to a folder I created years ago so I could find it.  I directed (browsed) the Wizard to that folder because it was looking at the external storage drive where I had stored it, otherwise the default settings location would be fine at this point.  The problem is I can't tell where the default location is.  Nothing I can find in System Options>file locations or HELP identifies the physical location of settings.  One would expect it to show up along with templates and such.

I created new settings in an assembly file and saved it with the Copy Settings Wizard to my made up folder.  That worked for assemblies but not for parts.  I even added the path to my setting's folder in System Options>Search Paths.

 

Not clear how the Wizard knows where my made up folder is, but SW doesn't.  It did occur to me that settings might be propagated through templates, but if so I still need to get SW to find the settings file.

 

Hopefully, the resolution will be embarrassingly simple.

Richard Dierks

Outcomes