17 Replies Latest reply on May 26, 2017 10:50 AM by Jim Steinmeyer

    assembly drawing showing (mostly) as hidden lines.

    Jim Steinmeyer

           First, I am using 2017 SP2.0 (installed 3.0EV yesterday to see if it would solve the problem - no luck) and we are running Win 7.

           I have a moderately sized assembly (4000 parts) that is giving me some erratic behavior when creating a drawing. The majority of the assembly is a reference sub-assembly, 25 of the total parts are not of the sub-assembly. When the drawing is created the sub-assembly shows as hidden lines while the new parts show as solid lines even though the view is set to Hidden Lines Removed. But the 25 new parts show correctly. I have hidden most of the components of the sub-assembly to be able to see the items relevant for the drawing but the lines were already showing wrong.

       

      Capture.PNG

      Capture1.PNG

       

           I have tried this model with different drawing templates with the same results. Then I created a new drawing of just the sub-assembly with most of the same components hidden and using the same drawing template and it worked fine.

       

      Capture3.PNG

      I have tried fooling the drawing by setting Tangent lines to "show with font" and changing hidden lines to show solid and that works for about 30 seconds and then reverts to the hidden font. Even before doing that the drawings will show correct while opening and then will revert to the hidden lines when fully regenerated.

           About a month ago I had another, similar drawing do the same thing where one sub-assembly (again the bulk of 41,000 parts) showed only as hidden lines and was never able to resolve it. This is a different but similar sub-assembly and again the rest of the components show fine. In both cases the models / drawings take about 5 min. to open but once open are easily maneuvered with no lag.

       

      Capture5.PNG  Capture6.PNG

           These are the only two drawings I have done that have exhibited this problem and it shows up when two of my co-workers have opened the drawings on their machines so I do not expect hardware issues. Both of these sub assemblies are pretty complete for our designed products so I am unable to upload the files and I have not been able to recreate this issue on a stripped down model to post.

       

           Has anyone seen similar behavior or have any suggestions as to how to resolve this issue?