16 Replies Latest reply on Oct 20, 2009 4:08 PM by Paul Kellner

    PDMWorks Problems

    Benjamin Lombard
      I recently upgraded my Solidworks Premium 2008 to 2009. Upon doing so, I am now unable to open all of my projects in PDMWorks. I can preview the files and it shows they are there with the correct revisions but when I try to Open/Check Out, I get the message "Error retrieving "(part #)" from the server. Do you wish to continue. If I log into the server and create a copy of the project and then try to open that project, everything works as expected. Any help is greatly appreciated.
        • PDMWorks Problems
          Christina Seay
          Did you upgrade your PDM solution to 2009 prior to upgrading your SolidWorks to 2009?

          I'm not sure... we're running 2008 of PDMWE and SolidWorks right now... but in the documentation I read about upgrading, it said that you have to upgrade PDMWE BEFORE upgrading SolidWorks... so that might cause that error if you didn't go in that order.
            • PDMWorks Problems
              Benjamin Lombard
              No I didn't. I didn't notice that information. Do you know how I might be able to fix that problem without having to re-install everything ?
                • PDMWorks Problems
                  Wayne Tiffany

                  Benjamin Lombard wrote:

                   

                  No I didn't. I didn't notice that information. Do you know how I might be able to fix that problem without having to re-install everything ?

                  I just ran across this in the release notes.

                  Compatibility with SolidWorks Enterprise Products
                  You cannot use PDMWorks Enterprise 2008 (or earlier version) with SolidWorks 2009.

                  WT
                    • PDMWorks Problems
                      Gene Mercer
                      We've been on PDMWE since '07 and encountered pretty much the same thing when we went to '08 and are currently in planning for '09. From what we've seen it appears to be somewhat OK if Solidworks gets a little ahead (Service Pack-wise) of the vault but you definately don't want to jump versions. There are several reasons, but the most important is even if you could store the '09 files in the vault, nobody could view them since your other users would still be using an older version of eDrawings.

                      Basically, a good general rule to remember is since SW will never open newer files (except maybe in the case of SP differences) always try and think of who will be using/seeing the files downstream. If they're not on the same major release as you, then your going to have problems one way or the other. Do your vendors/ 3rd party people have '09, are the file viewers (example above) upgraded, etc..

                      Gene
                        • PDMWorks Problems
                          Robert Thom
                          " Error Retrieving partxxx From The Server"

                          We are getting this error as well in 2009 when we went from serv pack 0.0 to 2.0.
                          This appears to have affected random parts (I can't link this to any specific attribute). But, if we try to check the same parts out in service pack 0.0 it works fine. So, this leads me to conclude that serv pack 2.0 has a bug in the "client" end of things. Please correct me if I'm wrong.

                          Also, I can open the corrupted parts directly from PDM (bypassing checkout).
                          I can save it locally and check it back in, but when you initiate a check out it will generate the error, remove it from your working folder and create a link in "My Computer" (go figure).

                          I also tried to save-as (copy) the corrupt part and it keeps the check out corruption error.

                          Any fixes???

                            • PDMWorks Problems
                              Marco Mintchev
                              I get the same error message "Error Retrieving partxxx From The Server" but in a different circumstances.
                              Some parts in my local PDM temp folder appear to be outdated (wrongly). When I ask SW to update all files from Vault I get the message for each part.
                              I have SW 2009 SP2.0 and PDMWorks Vault Server 2009 SP0

                              ciao

                              Marco
                                • PDMWorks Problems
                                  Robert Thom
                                  We fixed this error (at least for now). We had one of those illustrious corrupted SNL licenses that Solidworks put out there. See Dec 22, 2009 bulletin.

                                  http://www.solidworks.com/sw/s...ustomerBulletins.html

                                  Our vault tech also forgot to add Solidworks Explorer to our SP2.0 deployment so it could have been either of those 2 fixes that did the trick.

                                  Good luck, -FZ
                                    • PDMWorks Problems
                                      Jason Stats
                                      For what it's worth - We are still using PDMWE 2008 sp3 and have upgraded SW to 2009 and it seems to work just fine. The only thing that doesn't work is the preview window since eDrawings 2008 won't view the 2009 SW files. But we can change attributes in our data cards via PDM, check-in, check-out, undo check-out, etc. in PDM and within SW 2009. Not sure why it works, but it does!
                                        • PDMWorks Problems
                                          Carl Himpsel
                                          I am also getting the "Error retrieving part from server" message.

                                          SolidWorks Professional 2009 x64 edition SP2.0
                                          SolidWorks Workgroup PDM Add-In 2009 SP2.0 Build 0062
                                          SolidWorks Workgroup PDM Server 2009 SP0.0 Build 6014

                                          Fairly obvious that the first step is to upgrade the Workgroup PDM Server ("The Vault"). I've seen mention of SP1.0, is there a 2.0? I can't find a way to upgrade it, however. The "update" button in Help -> About SolidWorks Workgroup PDM is grayed out. There is an Enterprise PDM link downloadable from my Customer Portal (see attached picture), but no Workgroup PDM. Solidworks Installation Manager finds no updates.


                                          Thanks

                                          --------------------------------------------------------------------------------------------
                                          Update:

                                          Tech support solved my problem. Go to the original sldim that I downloaded (1st item in the attached screen shot), and update the server through that.
                                            • PDMWorks Problems
                                              Jeff Wilke
                                              We are running two vaults, and have just upgraded to 2009.

                                              Everyone is upgraded to 2009 sp2.1 and ONE of the vaults is at 2009 sp2.1

                                              Our other vault is at 2009 sp0.0 and we have the same issue "error retrieving..."

                                              Does anyone know if there is a separate install file for upgrading just the vault?

                                              __________UPDATE__________

                                              I did not know this area was available, might help out:

                                              From our VAR...

                                              To manually download the latest version of SolidWorks products and service packs:

                                              1) Log into SolidWorks.com customer portal
                                              2) Click on the "Downloads and Updates" link
                                              3) Click on the link for the relevant version of SolidWorks (2009 SP2.1)
                                              4) Accept agreement to continue
                                              5) Click the "click here" link of "If you experience a download problem, click here"
                                              6) Fill out the pull-down menus and then click "Continue"
                                              7) You will be presented with a list of available downloads and updates
                                              8) Choose from Step 5, "SolidWorks Workgroup PDM Server"
                                                • PDMWorks Problems
                                                  Brian Endres
                                                  I got the same message this afternoon and I believe that it may be tied to items in our PDM vault that are unable to be checked out (in our case, released files). If you go to your PDM Options and uncheck the box to turn the prompt off regarding checking out files that are opened "read only" it may solve the problem.
                              • PDMWorks Problems
                                Christina Seay
                                I honestly don't know. If you were planning on upgrading your PDMWE anyway you might could try upgrading it and see if that solves your problem. I would contact SolidWorks or your VAR and see what they suggest. I know you're not supposed to be able to run SolidWorks 2009 with PDMWE 2008 because it won't know how to handle the SolidWorks 2009 files correctly. If you don't want to upgrade PDMWE, you'll probably need to downgrade SolidWorks back to 2008.

                                We're in the process right now of upgrading PDMWE to 2009, but as of right now have no intention of upgrading SolidWorks, so I'm going purely off documentation that I've read and not off personal experience with it.
                                • PDMWorks Problems
                                  Ben Kalinowski
                                  We found the PDM version needs to be ahead of the SW version. We were on SW07 & PDM07 and we had to hold back the SW07 upgrade until PDM was upgraded. We were told the PDM version must always be ahead of or equal to the SW version.
                                  • PDMWorks Problems
                                    What is the error in the Archive Server Log file?
                                      • Re: PDMWorks Problems
                                        Paul Kellner

                                        "pdmwDataPortWorker::InitInstance() - CFileException() : An Existing connection was forcibly closed by the remote host.  (10054)"

                                        This line is present for every file and reference that PDMW could not open.

                                         


                                        The vault is on the same machine that the server and client are on.

                                         

                                        This error is actually quite common. A google search on "An existing connection was forcibly closed by the remote host. 10054" brings up 18,000 hits or so.

                                         

                                        One of the more meaningful results was, "A 10054 means that the host you are trying to talk to exists, but that the port does not exist or is blocked (i.e. firewalled)." The OP responded, "The issue turns out to be "User Error".  My FABRIC_ADMIN_ADDRESS was not set correctly.  Once I fixed that all was well." Not just sure what that means yet.

                                        Another site had:

                                        "WSAECONNRESET

                                        10054
                                             Connection reset by peer.

                                            An existing connection was forcibly closed by the remote host. This normally results if the peer
                                        application on the remote host is suddenly stopped, the host is rebooted, the host or remote network
                                        interface is disabled, or the remote host uses a hard close (see setsockopt for more information on the
                                        SO_LINGER option on the remote socket).

                                        This error may also result if a connection was broken due to
                                        keep-alive activity detecting a failure while one or more operations are in progress. Operations that
                                        were in progress fail with WSAENETRESET. Subsequent operations fail with WSAECONNRESET."

                                        From the MicroSoft WINSOCK2 Documentation:

                                        WSAECONNRESET     (10054)      Connection reset by peer.

                                        A existing connection was forcibly closed by the remote host. This normally results if the peer application on the remote host is suddenly stopped, the host is rebooted, or the remote host used a "hard close" (see setsockopt(SO_LINGER)) on the remote socket.