AnsweredAssumed Answered

Failed to load add-in ' ' when debugging PDM add-in

Question asked by Daniel McRae on Mar 29, 2017
Latest reply on Mar 20, 2018 by Amen Allah Jlili

Hi,

 

I'm trying to debug a PDM plugin and I just can't get the debug tool to load it properly. I've recently upgraded to Visual Studio 2017 and I wonder if that is making a difference, though I wouldn't see why that should matter. I've gone through PDM Add-in Windows 7 64 bit compatability with no success so far, so any further help would be really good. The plug in can load properly if it is registered as a non-debug add-in, but since it's crashing and I can't find out exactly where, this doesn't help at all! It's only when I try to load it as a debug add in that it fails to load. This was a working plugin that needed additional functionality for us to use it (found after testing), so it has been registered on the vault previously, and I've removed the add-in from the vault.

 

Things I've tried:

  • I've got the "Register for COM Interop" ticked.
  • I'm running Visual Studio with administrator rights so that it can register the dll in the right place
  • I was using Explorer.exe as the startup external program per the help files. This has worked previously, but now the error I was getting is "Failed to load add-in ''. Class not registered." (No path in the quotes.) (Recently when I try the same thing, explorer opens and then returns immediately. My computer might need restarting.)
  • Per the linked discussion, I'm trying to use Notepad.exe as the startup tool, and then it errors with "Failed to load add-in '<full path to dll>'. Class not registered."
  • Per the linked discussion, I've cleared out the C:\Users\<UserName>\AppData\Local\SolidWorks\SolidWorks Enterprise PDM\Plugins\<VaultName> folder.

 

Please, any suggestions? I'm about to debug the hard way if I have no other choice - create a log file that writes output for every line.

 

Thanks,

Daniel

Outcomes