4 Replies Latest reply on May 18, 2017 7:13 AM by Emma Gale

    Exploded View - Chain direction arrows stuck

    Emma Gale

      Hi,

       

      (Please see attached)

      (I am using 2016 SP 5)

      Does anyone know how I can get back the direction arrows to evenly space out the components?

      It will allow me one auto-space move per set but then the arrows change direction and I cannot get them back. The components are then stuck in this position and I cannot move them in any direction. It happens with most chains that I've tried it on. When I activate the rotation rings it still only shows the arrows in this direction. I am beyond frustrated at this point.

      I have only recently started working with exploded assemblies again and I don't ever remember them being so tricky.

        • Re: Expoded View - Chain direction arrows stuck
          Dan Pihlaja

          Personally, I never use the autospacing stuff.  Either I don't understand how it fully works, or I am just too OCD to like the results.

           

          I am using SW 2015 and I tried out a few things with an assembly, and while I could not reproduce your exact issue, I did find out that, after dragging the autospacing slider and then moving the components, if I want to modify their position after that, I either have to uncheck autospace and then drag each component to where I want it to go, or pretty much delete that explode step and try again.

           

          Either way, it seems to be faster to just drag the parts one by one to exactly where I want them to be.

            • Re: Exploded View - Chain direction arrows stuck
              Emma Gale

              Hi Dan,

               

              Thank you very much for your reply and my apologies for the extremely late reply.

              With your advice and a lot of trial and error I did manage to produce (a.k.a fudge) an acceptable result.

              Thankfully I've not had to work with explosions recently, it had become very frustrating to achieve what I wanted to do. I look forward to the next instance...

               

              Best regards

              Em

            • Re: Exploded View - Chain direction arrows stuck
              John Stoltzfus

              I've used exploded views a lot and have never seen that issue, did you edit the feature or are you just try and grab the arrows to move, not sure but I'm thinking that the chain explode is just a bunch of explodes done in one feature.

                • Re: Exploded View - Chain direction arrows stuck
                  Emma Gale

                  Yeah I'd not seen the issue before 2016. It was happening on the initial creation of the chain. It was like Solidworks was saying "ok you get a couple of goes at this to get it in the right position and if not, then tough luck." If I exited the chain then went back to edit it it would still happen.

                  I've not had to use the feature since March but I'm sure I will soon. Hopefully 2017 will be different.

                   

                  Lovely furniture btw John! I trained as a cabinet maker inbetween stints of engineering (which I'm currently back doing.) Your profile has reminded me I must get back in my workshop more!