6 Replies Latest reply on Jul 9, 2018 10:37 AM by Brett Erickson

    Graphical Glitch

    Phillip Laplante

      Hello,

      The issue I am having is whenever I click in the workspace the user interface breaks and displays part of the command manager and the feature manager, which stays on the screen for a few seconds then leaves once I move my mouse out of the workspace to certain portions of the screen, or click outside of the workspace.  Multiple clicks will produce this error again in one of those classic dragging windows situations.  This error happens in parts, assemblies and drawings and happens the worst when clicking on blank space, clicking directly on parts will produce this error but it will only show up for a split second before the selected entity is highlighted. Below is a picture of this glitch after 4 clicks.

      Solidowrks Graphical issue.png

      -Phillip LaPlante

        • Re: Graphical Glitch
          Christopher Estelow

          Phillip,

          This is most likely an issue with your graphic card.  Check to make sure it is a SolidWorks approved card and that you have the latest driver installed.

           

          Check your card here - Graphics Card Drivers | Hardware & System Requirements | SOLIDWORKS

           

          Run Solidworks RX diagnostics and get back to us.  It is listed under Solidworks in your programs under the start bar (using a PC)

          2017_02_21_07_43_14_Start_menu.png

           

          Hope this helps,

          Chris

            • Re: Graphical Glitch
              Phillip Laplante

              Hello Chris,

              I did some more research and did find out that this is indeed a graphics card issue, mine is an Nvidia GTX 960, which seems to be not supported by Solidworks.  I also did try getting the latest driver for my graphics card, but it was already up to date.  I found out when I run Solidworks using OpenGL the error did stop, but of course that is not a permanent fix.  However, I also tried to reproduce this error again without OpenGL when I replied to this post today I could not get it to happen, so this leaves me even more confused than when I started.  Is there any way to help prevent it from happening in the future?

               

              -Phil

                • Re: Graphical Glitch
                  Christopher Estelow

                  Only thing I can think of if get an approved card and you shouldn't have any problems.

                   

                  Chris

                  • Re: Graphical Glitch
                    Dennis Dohogne

                    Phillip,

                    So, here is what you did 1) had the problem, 2) enabled OpenGL - no problem, 3) disabled OpenGL - also no problem.

                    I'm guessing that somewhere between 2 and 3 you closed out of SWX completely and/or rebooted.  Since you did not actually update your video driver it is a puzzle what could be going on.  Although, I have seen where some software, including graphics software, can get confused and just needs to be rebooted.

                    • Re: Graphical Glitch
                      Rick McDonald

                      I have been seeing a lot of posts related to graphic card issues with the GTX 960 card.

                      What they told us at SWW in the Administrators boot camp, was

                      when you have a graphics problem be sure you do NOT have the latest driver for the card.

                      SWX does not get the drivers with enough time to even test them - let alone certify them.

                      Often the drivers are released with little or no notice to SWX.

                      The recommended action is to find the latest CERTIFIED driver and use that and disable the automatic updating of your graphics drivers.  If your board is not certified at all (the GTX cards are not certified) then you should still try older drivers and see if the problem clears.

                  • Re: Graphical Glitch
                    Brett Erickson

                    I had this same issue with Windows 10 and it is related to the windows scaling behavior. Right-click on your desktop background and select "Display settings" then go to the "Change the size of text, apps, and other items" to 100%.

                     

                    Or you can disable the scaling for SolidWorks alone. You right click on the SLDWORKS.exe in the install directory then go to the Compatibility tab. Next you select the "Override high DPI scaling behavior". Finally in the dropdown select "Application". This will prevent Windows from trying to scale SolidWorks causing the tiling affect you're seeing.