13 Replies Latest reply on Feb 10, 2017 11:49 AM by Dan Pihlaja

    Mass Properties Inconsistent

    Asa Eckert-Erdheim

      Hello.

       

      Mass properties has been giving some off results recently in assemblies. I've eventually narrowed down the issue as to whether or not I run Assembly visualization. In short, if I open an assembly and go to mass properties, it comes out to 4.9kg. If I run assembly visualization and then re-run mass properties, it measures at 5kg. I can replicate this consistently in my assembly.

       

      I've tried most things I can think of (setting all parts to resolved and rebuilding, turning up accuracy of mass properties, ensuring the hidden components is checked), but so far the only determining factor is whether or not I've run assembly visualization after the assembly is opened.

       

      It seems like a bug, but maybe I'm missing something. Weight is also somewhat important, so if someone else has had this issue and verified it, is the higher or lower mass usually accurate (I assume that unfortunately its going to be the higher one).

       

      I'm running SW 2016 x64 SP 0.1