8 Replies Latest reply on Sep 17, 2018 5:23 AM by Martijn Heikens

    Design table not starting

    Esa Lehtinen

      Hey,

       

      I have a wierd problem, when I try to create a new design table the tool starts (I keep the basic settings) and hit the green tick to start the table creation on auto, nothing happens. Program just doesn't do anything.

       

      I am running SW2017 SP1 and Microsoft Office 365 Excel 2016.

       

      Any ideas what might cause this?

        • Re: Design table not starting
          John Stoltzfus

          How is your Design Table setup??

           

          • Re: Design table not starting
            Jim Paige

            I experienced the same problem this morning.  Rebooting fixed the issue but since I don't know what caused it to begin with, I'm sure it'll happen again.

             

            SWX 2017 SP1.0 64-bit

            Microsoft Office Standard 2010 32-bit

            • Re: Design table not starting
              Roy Potter

              I'm using SW2016 SP5.0 with Office 365. I had the same issue.

              I managed to resolve this by closing all windows that could be accessing excel, including explorer windows.

              I restarted SW and opened the file that I wanted to create the Design Table in and created the table.

               

              I double checked this by opening a folder and hi-lighting an excel file (with preview active), then I created a blank SW part and tried to create a design table. the table wouldn't create.

              I closed the explorer window with the hi-lighted excel file, went back to my SW part and was able to create a design table.

              • Re: Design table not starting
                S. Casale

                My experience with design table creation and editing is that the SW file always needs to be completely rebuilt and saved before starting the command- sort of a rule of thumb anyway right?

                • Having more SW windows open while trying to create or edit a design table causes instability.
                • When selecting the design table for creation or editing, don't click away from SW while the software is processing. Be patient, being click happy is not good (this is said for any time that SW is processing).

                 

                I know it's not the answer but it ought to help.

                • Having many other excel files open at once causes issues.
                • Excel is already open when starting a design table and if a cell is in the process of being edited, no excel function properly responds/works (open, new, etc) in any other excel file - until the specific cell is no longer selected or being edited (redundantly stating: this occurs not just with SW).
                • Re: Design table not starting
                  Bret Detavernier

                  Esa, I am also having same issue with SW2016-17 and MS Office 365, my Design Table looks just like the image John sent and after starting Design Table the Excel window appears with only the title blocks populated no measurements and then a second window "creating design table" appears with progressive green bar then third window appears with red X " unable to set the interactive property of the application class" . I have tried all the advice mentioned in thread so far and others, any help would be appreciated .

                  • Re: Design table not starting
                    Martijn Heikens

                    Running SW2017 SP5 and Microsoft Office 365 Excel 2016

                     

                    Same issue arose here.

                     

                    Workaround (not the solution) to first manually create a excel. Be sure to modify Cell A2 description to Family, add all the configurations you already made starting from cell A3 downwards and add at least the descriptions (populate cell B2 with: $DESCRIPTION).

                    SW_DT_Excel.PNG

                    Save the excel file.

                     

                    When you have the desired model open start the designtable and select "From file"SW2017_DT.PNG

                    Browse to the saved file and let it import. you can now edit the design table as usual.

                     

                    Will try reinstall of SW later to see if that will resolve the issue.