AnsweredAssumed Answered

manually overriding assembly references

Question asked by N. Ritchey on Jan 23, 2017
Latest reply on Jan 31, 2017 by N. Ritchey

is there a way to manually change an assembly part file reference? for context, here's what happened:

 

joining a new project, the only model data we have is conceptual from the design phase.

 

now we are assigning part numbers and organizing our data. so i used the solidworks shell extension to rename files (right click in windows > solidworks > rename... this launches a SW applet that will change the filename and correct references)

 

i used this to rename all the files to use their part numbers as their file names.

 

UNFORTUNATELY, i accidentally renamed one of the files omitting the "." between the P/N and "SLDASM". resulting in one file being named NNNNSLDASM (no windows file extension)

 

this seems to have confused the top level assembly. when it searches for the document, it's looking for a DRAWING (.SLDDRW) and not an assembly. if i manually point to the assembly file, it tells me the file is "invalid or incompatible"

 

the icon in the assembly is different as well. instead of a typical part of assembly icon (the tetris block), it's a small capital L.

 

this tells me that i messed something up when i accidentally replaced the reference for a .SLDASM part to one with no extension.

 

NOW when i open the top level assembly i'm prompted to locate the file. again, it wants me to find a SLDDRW file and won't accept the SLDASM. whenever i try to run the Replace Component command solidworks instantly crashes.

 

i've used the SolidWorks shell extension to try and rename this file back to its "NNNNSLDASM" (no extension). curiously enough, when i run the SW shell renamer, it no longer sees the association with the top level assembly like it used to.

 

my references are screwed up. is there any way i can manually override this reference without using the Replace Component command? i'm trying to avoid re-mating dozens of parts and subassemblies.

 

i tried examining the files in SW Explorer. the problem subassembly (NNNNNSLDASM no extension) shows no association in the "where used?" inquiry. the top level assembly lists "NNNNNSLDASM (no extension)" as a referenced part. the icon is that of an image file. when i right click on this link the options for "move" and "rename" and "replace" are grayed out.

 

it really also doesn't help that this is the first subassembly in the top level assembly. it serves as a grounding mate for every other component and subassembly.

 

THANNANNNNNANNNKS

 

ALSO

 

in the open dialog you can click on "References..." to manually view and update references. here, solidworks is telling me that i cannot replace the file with one of a different type (parts to assemblies, assemblies to drawings, etc.) but solidworks already changed that automatically and now won't let me change it back.

Outcomes