19 Replies Latest reply on Nov 9, 2017 12:08 PM by Richard Gergely

    Unable to associate X_T files with solidworks

    Patrick Norton

      I am running Windows 10 Pro and Solidworks 2017 x64 SP1.0

       

      I can open files that are by default associated with Solidworks without issue.

      I can do this both from within Solidworks or if I click on the file in my windows File Explorer.

       

      From within a running instance of Solidworks, I can also open an X_T file from "File->Open".

       

      But in my Windows File explorer, I cannot open X_T files.

      I tried to use "Open with" ... but Solidworks is not listed as a default option.

       

      So then I selected "Open With", browsed and selected the application:

      C:\Program Files\SOLIDWORKS Corp\SLDWORKS

      But Windows tells me:

      "The program you have selected cannot be associated with this file type. Please choose another program."

       

      So I tried associating it to the file "swShellFileLauncher" in the same location.

      That seems to open Solidworks but gives me the error:

      "An error was encountered while trying to open your file. Contact technical Support for a possible solution."

       

      Can someone please tell me where the appropriate application to associate files with is located or what I am doing incorrectly?

       

      Also,

      I frequently use 2 instances of Solidworks at one on side by side screens.

      So the solution will need to incorporate that ability.

       

       

       

      thanks