10 Replies Latest reply on Dec 21, 2016 6:59 PM by John Willett

    All Text is Red!

    John Willett

      All "Notes" or "Dimensions" I enter are Red.  This started sometime yesterday in SW Premium 2016 SP5.0 under Windows 7 SP1.  I've been trying to learn how to do drawings (no formal training), and yesterday I was playing around with "Hatching" surfaces in different solid colors.  Actually I got the hatch colors by placing the hatching on newly created layers set to different colors for that purpose.  I didn't knowingly change any Options or color settings.  I got confused at one point with wrong-color hatching appearing, but seemed to have fixed that.  Now, however, on every drawing I open, new or old, in every instance of SW, text or dimensions come in red, no matter what layer I put them on, even the Format layer.  (Fortunately model views are still black.)  I can change it's color with the Line Format toolbar, of course, but this is a chore...

       

      Any idea what I did wrong and how to fix it? -- John Willett

        • Re: All Text is Red!
          Glenn Schroeder

          There are a several things it could be. 

           

          1.  Your active Layer is red, which will override Document Property Settings.

          2.  Red is the active color on the Color icon on the Line Format toolbar.

          3.  "Color Display Mode" is selected on the Line Format toolbar.

           

          See #9 at Frequently Asked Forum Questions for more information.

          • Re: All Text is Red!
            John Stoltzfus

            Toggle this

             

              • Re: All Text is Red!
                S. Casale

                MY money is on this as the fix!

                  • Re: All Text is Red!
                    John Stoltzfus

                    In reality using this is never a fix, line and text colors are a real Pain to straighten out, there are layers, there are options galore and in the layer color chart "default" need to be checked

                     

                     

                    If you use layers your layer setting needs to be "Per Standard" - unless your working with a layer

                     

                     

                    You need to have all your Dimensions - Notes - Tables and Views pointing to the proper layer, "If" you use the layer options

                     

                     

                    Then like Doug Seibel mentions you need to dive in here

                     

                     

                    I have just changed over to Layers and I really like them a lot, however sometimes settings don't work cleanly and you end up doing a lot of extra work..

                     

                    When you have something that works well for your workflow, important............ Save your Drawing Standards and Copy your settings using the Copy Wizard..

                      • Re: All Text is Red!
                        S. Casale

                        Understood and Agreed.

                         

                        We use colors very rarely. I've implemented a few layers for specific things such as FAI inspection bubbles and marl-ups when done in the actual slddrw (to be changed at implementation).

                         

                        Most of time there have been colors on dim's its been a user lack of knowledge when we were transitioning from ACAD circa 2008. So we don't really have this issue.

                        • Re: All Text is Red!
                          John Willett

                          Thanks very much (to all, in fact) for the very comprehensive discussion of this issue.

                           

                          >>in the layer [line?] color chart "default" need to be checked<<

                           

                          My problem seems to be some combination of the Line Color Default box not being checked and the Color Display Mode toggle being set wrong -- too bad there is no obvious indication of this last setting!  After fixing this (I hope) my "permanent" solution is to remove this toolbar from the screen!  (Unfortunately I only added it to fix the problem after it occurred, so I still don't know how I got into this mess...)

                           

                          Anyhow at this point I've modified my custom Documents Template with several items - notably the System Options/Colors -- set back to defaults and with the Layers for Notes, Dimensions, etc. set to the layers I want.  Just two questions about your suggestions that I could not follow:

                           

                          >>If you use layers your layer setting needs to be "Per Standard" - unless your working with a layer<<

                           

                          I could not find anywhere that the list of options you imaged shows up, nor do I understand exactly what you mean here.

                           

                          >>Save your Drawing Standards and Copy your settings using the Copy Wizard.<<

                           

                          I can't find any "Drawing Standards" to save.

                           

                          Thanks again! -- John Willett

                            • Re: All Text is Red!
                              John Stoltzfus

                              John Willett wrote:

                               

                               

                              >>If you use layers your layer setting needs to be "Per Standard" - unless your working with a layer<<

                               

                              Here is the Layer Toolbar, with a drop down arrow    Click on the arrow and the words -Per Standard- should be in the list

                               

                              I could not find anywhere that the list of options you imaged shows up, nor do I understand exactly what you mean here.

                               

                               

                              Your Drawing Standards Options are in the Tools/Options/Document Properties - you need to save first, and then you can load that saved setting later, if needed.  If I open an old file, assembly, part or drawing, I will load my latest Drawing Standards...

                               

                               

                              >>Save your Drawing Standards and Copy your settings using the Copy Wizard.<<

                               

                              I can't find any "Drawing Standards" to save.

                               

                              Thanks again! -- John Willett

                      • Re: All Text is Red!
                        Doug Seibel

                        First place I would look is in System Options - Colors.

                        Click on the top/first item in the "Color scheme settings" list and then use the down arrow key on your keyboard to start moving down through the list.  Watch the color to the right of the list change as you work down the list.  When it is the color red, stop and look at what you are on in the list.  Odds are that you changed the "Dimensions, Non Imported (Driven)" color to red.

                         

                        (Or just go to "Dimensions, Non Imported (Driven)" and click on it to see what color it is set to.  But when you have accidentally changed a color in Solidworks and the change is rippling through to everything you open, it generally means you made a change in the "System Options - Color" settings in Solidworks.  And while you may not know what Solidworks calls it, you will at least know what color it is.  So by working your way down through the list and seeing what color everything is, you can often find the offending color and then look and the name and see if the name makes sense for what you are wanting to find/change.)