3 Replies Latest reply on Dec 19, 2016 9:17 AM by Scott Ellery

    Visualize 2017 has given me nothing but problems

    Andreas Olofsson

      Alright, so I've been waiting a while for our license server to be updated so that I could upgrade Visualize from 2016 SP0 to 2017. I had updated once before to 2016 SP1 but had to downgrade back because the update changed my HDR lighting drastically from how it looked back in SP0.

      Now that I'm finally able to update to 2017 I am very dissatisfied to learn that my HDR issue still hasn't been fixed. My VAR won't update me on the status of the issue. Seems like it's been totally abandoned since the SR's status says "closed". I've spent a lot of time setting up all of my 50+ projects so that the lighting looks good, from all angles. Now it looks like crap. Spent a couple of hours trying to make a new HDR but I can't get anywhere close to how well it looked before.

      Great.

       

      I render a lot of turntables, which need to consist of 48 frames. 2017 offers me the option of either 47 or 50 frames. Isn't that neat. Terrific.

       

      And last but not least; Visualize cannot handle the apparent complexity of my motion studies. That was the biggest reason for me to upgrade. It freezes for at least 10 seconds in between every single mouse click, even in preview mode. The already tedious task of applying appearances to every part just got even more cumbersome.

       

      Looks like I've got no choice but to downgrade again. Lovely. Pardon the sarcastic tone but I am properly pissed... Better luck with SP2!

       

      PS: I had a hunch that it would be a bad idea to have "create movie" be enabled by default. And it turned out I would be right to be concerned. It cannot be disabled if there are render passes enabled. And you can't disable the render passes if create movie is enabled. Paradoxical...

      The reason the render passes are ticked is because those were my output settings for the last session. Create movie was not ticked then. But because Visualize assumes that everyone wants that option enabled it goes ahead and ticks it for us no matter what it was set to the last session.

      I never, ever want to have that option enabled. I assemble all of my frames in After Effects, along with their render passes.

       

       

      PPS: When opening my default project that I use to import all of models into, it crashes Visualize. That's also new in 2017!

        • Re: Visualize 2017 has given me nothing but problems
          Brian Hillner

          Hi Andreas,

           

          First off, let me apologize for all the issues and frustrations you are having with 2017 SP0/1. You always produce amazing content from Visualize, as showcased by one of the new splash screens for Visualize 2017.

           

          Thank you for the constructive criticism. All of your feedback here has not fallen on deaf ears and we will work to address these issues.

          The Visualize R&D team worked their butts off to introduce a ton of new functionality between a very short dev cycle of 2016-17. We also ramped up a passionate QA team to help catch these issues before they reach production versions. So rest assured, Visualize will be more stable with each coming service pack.

           

          I have a hunch that the HDR issue was due to a change that we had to implement from Iray, the render engine inside of Visualize. They corrected an issue with how they calculated the HDR, which actually is an improvement over the old way we did it (allows for more correct transparencies, reflections and refractions. So that's probably why the lighting is slightly different between your 20176 & 2017 projects. Core changes like this happen very rarely.

           

          We will be in touch with you via direct email to capture crash logs and also sample projects for us to debug. This will be the best way to reproduce the issues you are having, and implement a solution.

           

          Thank you always for your honesty; it will continue to make Visualize better with every release.

           

          Best Regards,

          Brian HILLNER

          SOLIDWORKS Visualize | Product Manager

          • Re: Visualize 2017 has given me nothing but problems
            Bastian Krueckeberg

            Hi Andreas,

             

            I am very sorry that Visualize 2017 SP1 did not meet your expectations! I am concluding the following 4 issues from your comment above:

             

            Issue 1 - Turntable cannot be rendered out using 48 frames

            We are planning to address and fix this for Visualize 2017 SP2. For now, I found a workaround to this problem:

            1) Check "Create Movie"

            2) Set "Frames Per Second" to 25.00

            3) Uncheck "Create Movie" again

            4) Enter 48 in "Number of Frames"

             

            Issue 2 - Create Movie cannot be unchecked

            This is already fixed and will be shipped in Visualize 2017 SP2 as well. It was brought up before in this forum: Was the default Turntable function changed in 2017? It looks like you are also aware of the workaround to disable all render passes.

             

            Issue 3 - Poor performance with complex motion studies

            I would appreciate if you could share your data set with us in order to profile this and find the bottleneck. If this poor performance is really caused by the complexity of the motion study, it may help to hide all animation ribbons in the Timeline (Timeline > Show/Hide All Animation Ribbons in Viewport, this is in the top left corner of the Timeline window).

             

            Issue 4 - Change in HDR lighting and reflections

            There was a bug in Visualize 2016 which itself was a regression to Bunkspeed in the past and which was fixed by us. I assume that the unwanted change in lighting that you are experiencing now is a consequence of us having brought back the expected behavior. This occurs if for an HDR Environment, both "Show Environment Image" is unchecked and "Floor Shadow" is checked. Is this assumption accurate in your case?