12 Replies Latest reply on Jan 29, 2013 1:40 PM by John Ehrhardt

    disabling dimension property manager

      is there any way to make solidworks not show dimension property manager each time i click on a dimension in a sketch? i don't use it and it takes an annoying time for the prop manager to show up. also i want to go directly to modify dimension dialog box whenever i double click a dimension without property manager.
        • disabling dimension property manager
          any solutions?
            • disabling dimension property manager
              Andy Fraser
              Hi Tim,

              If you go to options, under general, about 2/3 the way down you will see two options for controlling the property manager, but they affect the whole system, not just dimensions. I am not aware of a way to turn off just the dimensions PM.

              Uncheck "Auto-show PropertyManager" to disable all the PMs.

              Regards,
              Andy.
                • Re: disabling dimension property manager
                  Dan Zimet

                  I tried this and the property manager keeps poping up when I don't want it to. Also, sometimes it pops up in bad locations and I am not able to move it or get to the bottom portion of it because it extends below the bottom of the screen. This happens in drafting, as well as sketching and other times.

                   

                  Running Solidworks 2009.

                    • Re: disabling dimension property manager
                      Tom Spine

                      EDIT: Now that I re-read the original post, I see that I'm mistaken as it about clicking on dimensions in a sketch. Was reading too fast. Nevertheless - I *am* still looking for people to give me feedback out the Dimension Palette!

                       

                      My original reply follows:

                       

                      I think you are referring to what is called the Dimension Palette, rather than the PropertyManager. The Dimension Palette is the thing that pops up in the drawing area when you click on a dimension:

                      dim_palette.jpg

                      This has been discussed in other threads, but, no, in SolidWorks 2010 it cannot be turned off. We are aware of the usability complaints about the Dimension Palette, and we are going to be addressing them. I have heard many of you say "just let me turn it off." I am also working on design alternatives so that when it is on, it does not get in your way.

                       

                      I will put out another plea - if any of you can spare 30- to 45-minutes to try out a development prototype and give me feedback (via a GoTo Meeting - no travel necessary!), I am running feedback sessions now. I want to ensure that any changes we make are done right, and getting your feedback is critical. I know I'm running into end-of-the-year crunch time and people also taking time off over the next two weeks, so I will probably continue to collect hands-on feedback into January. If you have a half hour to help out and give me one-on-one feedback on our development prototype, please contact me directly at tspine at solidworks dot com. Thanks!

                       

                      Tom Spine

                      SolidWorks User Experience

                        • Re: disabling dimension property manager
                          David Anderson

                          although i do greatly appreciate your effort to make it "better" by asking users to test drive a dev proto to get more feedback, i would like to submit the  motion that in the mean time, use the feedback you have and provide the ability to turn it off.

                           

                          any seconds to this motion?

                          • Re: disabling dimension property manager
                            Dale Dunn

                            Feedback on the dimension palette maybe should have it's own thread. Or maybe there was one and I missed it. I'd volunteer, but I haven't been able to do any work on 2010 yet. If you want an uninformed opinion (discoverability or something) let me know.

                             

                            Back to the original topic... I have a similar problem with the dimension property manager and the dimension modify box (what became the dimension palette in 2010), taking a vew very annoying seconds to open. I asked about it here several weekes ago, and nothing anybody suggested helped. I've been waiting for a lull in work deadlines to rebuilt the computer and see if that helps. Something's wrong when my 3-year-old laptop is near instant, and this Core i7 965 takes a few seconds.

                              • Re: disabling dimension property manager
                                Anna Wood

                                Dale,

                                 

                                Does it take a few seconds to open when you first launch a SW session, but will appear quickly when invoked again in the same SW session?

                                 

                                SW used to load every possible DLL needed in a session of SW.  They have changed that behavior to load a lot less DLL's so SW will open faster.  This means that when first invoking a command in a SW session, that SW may need to load the required DLL causing a bit of a delay.

                                 

                                Not sure if this is what you seeing.

                                 

                                Are you running the same version of SW on your laptop and workstation?

                                 

                                Cheers,

                                 

                                Anna

                                  • Re: disabling dimension property manager
                                    Dale Dunn

                                    Anna,

                                     

                                    I get the delay every time, unless the property manager itself is already open. You don't remember, but we already discussed this in another thread. For full disclosure, the laptop is currently on 2010. I don't remember it exhibiting this behavior when I had 2009 on it though. I only mentioned my problems in this thread to try to help clarify the problems of the OP, and to rant a little.

                                     

                                    Thanks for checking in again.

                                • Re: disabling dimension property manager
                                  Dan Zimet
                                  Not sure why this thread diverted to the Dimension Palette.  Any suggestions on why Solidworks is ignoring my disable/uncheck of AutoShown Property Manager??
                          • Re: disabling dimension property manager
                            John Ehrhardt

                            I agree that the large dimension property manager is a distraction.  It requires time to appear and it covers up my work.  What is needed is a menu pick option to access this PM as needed, not every time something is picked.   I can make an enhancement request too.  More votes should help.

                             

                            Update-

                            property manager is starting OK in my 2012 version.

                            The local dimension palette is very helpful.  I like fast access to the dimension settings; as long as it is not covering the item being edited as property manager will do. My other CAD allows R-c popup of a dimension manager in drawings. The cursor is active on the number of digit places which can be adjusted with left hand on cursor keys for less mouse picks.

                             

                            It still does not disable-

                            Disabling Auto Prop Mgr still allows a PM to explode over a fourth of my screen in 2012 SP5. A smaller PM appears in 2013 SP2.